PDA

View Full Version : IK blend problem


Ehssan
03-04-2010, 08:42 AM
I have a problem when I`m rigging an arm for my character. I have 5 controllers(bicep/elbow/Wrist/pole vector/IK controller). I used constraint/orient for my joint to controllers. when I do this I cannot change IK blind attribute of my IK because all joints and controllers rotate into each other and my skel get into problem.So everything works except IK Blend. Help me please.

Darksuit
03-04-2010, 02:36 PM
Found the Problem... =)

Constraint/Orient -- can you tell I dislike this constraint a lot?

But in all seriousness. With out seeing anything its a bit of a guess to suggest what is wrong.
When I do a FK/IK blend rig I actually don't use any constraints at all. I use Blend Color nodes and use the straight rotations so that everything blends smoothly and I can control the speed of the blend.

http://www.darksuit.com/tutorials

There is a link to my stretch FK/IK arm Rig. If you open that up and select any of the arm bones, then open the HyperShader and show inputs and outputs you can see what I am doing here. When I do this on a character Rig I parent the arm Rig onto the Clavicle so that all Arm controls move as one.

musi
03-05-2010, 03:22 PM
I do the same as Darksuit.
Constraints in the ik-fk blends is a disaster waiting to happen, and it will soon or later.

jamill71
03-22-2010, 10:42 PM
Hello Darksuit

"I use Blend Color nodes and use the straight rotations so that everything blends smoothly and I can control the speed of the blend."

I like the idea of using the Blend Color node to accomplish the Ik Fk switch and I would prefer it to constraints, but with the Blend Color node the arm bind skeleton seemed to be getting transformations from both Ik and Fk arm skeletons when I moved the upper body of my character. Otherwise the Blend Color node seemed to work fine for going between Ik and Fk. I had to swap out the Blend Color node for Parent Constraints which took care of the double transformation problem.

Do you have any thoughts on why this might happen?

Thanks

Darksuit
03-23-2010, 11:42 PM
The initial blend value of the color blend node is set to .5 so that it is already blending both the joint rotations to begin with. You need to have a control that will set the value of the blend channel in the color blend node. There is a whole section in the tutorial on this. or you can take a look at the FK IK Stretchy switch arm and backwards engineer that. It's pretty straight forward. =)


double transforms are usually due to a heirarchy issue. Nothing more. In most cases you canm set a control or bone to not inherit transforms to correct for this issue. Without seeing the rig I can't point to the specific problem. just sort of point you in the general area of what might be (or in this case) more than likely causing the problem.

jamill71
03-24-2010, 11:38 AM
Thanks for responding

If I could find that old file of mine I'd attach it. Oh Well... I'll give Blend Color nodes another try next time I do an Ik/Fk switch.

Best

CGTalk Moderation
03-24-2010, 11:38 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.