PDA

View Full Version : Simple questions, probably simple answers.


SadamHu
02-22-2010, 11:09 PM
Question #1

When I model i have to go inside to
fix problem areas (quite a bit actually, lol)
How do I make the backfaces shade exactly
like the frontfaces?

Question #2

When Importing a model from outside
programs like Zbrush or Maya, the normals
are inverted (depending on what i was doing!).
This is because the copy was scaled negatively
in X and the normals also flip. I have tried simply
to just flip the normals aswell as some of the other
functions I can find. When I have flipped the
normals and then subdivide preview the normals seem to flip!
But here you can see in the last image that the normals are fine!
But they are still showing as though they are black?
What would be causing this? and whats the fix?

Thanks very much for you help.


http://img442.imageshack.us/i/question1a.jpg/

http://img26.imageshack.us/i/question2a.jpg/

http://img26.imageshack.us/i/question2b.jpg/

http://img26.imageshack.us/i/question2c.jpg/

http://img26.imageshack.us/i/question2d.jpg/

http://img26.imageshack.us/i/question2e.jpg/

ThE_JacO
02-26-2010, 12:48 AM
How do I make the backfaces shade exactly like the frontfaces?
You can't. If they are single sided (don't shade non facing polys) they won't show up, if they are shaded on both sides the light interactions are simply different on the two sides.

When Importing a model from outside programs like Zbrush or Maya, the normals are inverted (depending on what i was doing!).
You probably have a custom normals cluster on that model coming from the obj. Delete that and the normals will be autocomputed by Soft, and an eventual invert normals will behave as you'd expect it to if it's needed.

SadamHu
02-28-2010, 06:09 AM
where do I find this cluster? in the explorer? I only see a geometry approximation node. Which I delete and it doesnt solve the problem.

Jettatore
03-01-2010, 12:33 PM
Don't delete your Geo Aproximation node. Instead, look slightly above where Geometry Aproximation is listed and find the heading "polygon mesh" and expand that category. You will see a clusters folder. This folder holds all of your of clusters, including your models UV's if it has them.

If you don't get the option to "expand" the polygon mesh folder, then in the explorer up top in the menu, make sure your set to "All Except Params".

grahamef
03-01-2010, 05:48 PM
You can't. If they are single sided (don't shade non facing polys) they won't show up, if they are shaded on both sides the light interactions are simply different on the two sides

Maybe he's asking for Hidden Line mode?

CGTalk Moderation
03-01-2010, 05:48 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.