PDA

View Full Version : OpenGL issues..


Helix
05-21-2002, 02:57 PM
I'm trying to get Maya, XSI, and Lightwave working on my system, but all 3 crash at startup. they used to work fine, but i screwed with some OGL minidrivers and G/fx card drivers and i think something is out of whack on my system.

when i start maya i get this error in the output window, and it repeats indefinitely:

(hwcExecuteStatusWinFifo): Invalid fifoTypegd error


i looked it up on google and it returned info about opengl so i figure my messing around with drivers screwed it, but nothing was specific to my problem. With XSI/Lightwave, they get to the interface and freeze before loading the panels.

if anyone has any idea what i can do to fix this, let me know. i tried reinstalling maya, and that didn't work. i reinstalled the factory drivers for my graphix card, and also tried to put the original opengl32.dll back into my system32 dir, but neither that, nor replacing it with another proprietary version, did any good.
help is greatly appreciated! :beer:

3DMadness
05-21-2002, 03:08 PM
Hi!

It will be difficult to help without some information about your hardware and operation system.
Please, tell us what is your graphic card, motherboard, processor, RAM and other hardware stuff that you have in there. Also is important to know what OS do you use and driver/patches installed on it.

Cheers!

Flávio

Helix
05-21-2002, 03:13 PM
my computer setup is pretty sad right now, i'm getting ready to do some massive upgrading :)

processor- 500mhz p3
mem- 256mb sdram
graphics- 3dfx voodoo5500
os- win2k

as i said, it worked before so it shouldn't be hardware conflicts. i installed wickedGL to run a couple games, and went to voodoofiles.com and tried several video drivers for my card, but i uninstalled that (to my knowledge) and reinstalled factory stuff.

thx 4 the help!

ZrO-1
05-21-2002, 04:49 PM
My guess is that this is direcly to do with your card and not the 3D apps themselves. The high-end 3D apps need OpenGL in a window (or multiple windows), and I don't think the VooDoo's even support that. The 3Dfx drivers are kind of wonky in any case for windowed mode, so thats my guess what might be happening. The voodoo isn't a 2D wonder, and it's 3D technology is really long in the tooth.

I can't remember if the Voodoo3 (or 4/5) supported windowed 3D/Opengl, but Glide I know doesn't (it's full screen only - as is the Voodoo1/2 cards in any mode).

To be honest I don't know how you got it to work in the first place. Sorry I can't be more help.

Helix
05-21-2002, 06:18 PM
would proprietary drivers for the card fix the windowed probs? maybe that's how i got it to work before.

i've played unreal in a window with this card :)

ZrO-1
05-21-2002, 11:03 PM
Ya got me dude. One thing I can tell you is that games and 3D apps are quite different. I wouldn't say that just 'cause a thing can be done in a game it can be done in a 3D app. Look at the huge difference in performance with gaming cards and pro cards, and vice-versa. They don't swap jobs very well, and when they do there's always a sacrifice one way or the other.

Helix
05-22-2002, 02:10 AM
this is where i sulk heavily and spend lots of cash on new parts. :(

CGTalk Moderation
01-13-2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.