PDA

View Full Version : Displacement maps - ZBrush 3.5 <-> Cinema 4D


Spitfire-X
02-01-2010, 07:14 PM
Hey!

I just have a little problem with exporting and applying displacement maps from zbrush to Cinema 4D.

This is my workflow so far:

• Building the base mesh in C4D
• Build UVs with the automatic assistant from Body-Paint 3D
• Export the mesh as OBJ
• Import the OBJ as tool in ZBrush
• Sculpting on that tool
• Export a displacement map from ZBrush
• Import the displacement map into the displacement-channel of the material
• Apply the material to the mesh
• render

... well, the mesh is just a bit smoother but nothing of the sculpted displacement seems to be in place or even applied. Some bumps and scratches here and there - but no real shape.

I already tried to find some answers via google and checked some tutorial videos on youtube - but I just followed the steps in the tutorials - with no result.

Maybe there are some important settings I missed out?

Hope anyone can give me a hint!

Thank you!

Cheers,
Gary

flingster
02-14-2010, 04:18 PM
maybe try posting the same question in the c4d forum :thumbsup:

Magyareagle
03-01-2010, 02:50 PM
Usually, the problem is either with your program specifically, or with the normal map not being dense enough. In addition, keep in mind that Zbrush flips your UV maps upside down. Place the normal map under a projector in the texture settings, and then change the mode to UVW, and make the Y value -1 (-100%). If that still isn't working (and it sometimes happens when using not using tangent maps) import your normal map into Crazybump as a color map, and export as a normal map. I've gotten great results that way.

Spitfire-X
03-08-2010, 03:48 PM
Thank you for your answers.

I found a video on youtube which solved my problem with some quite easy settings.

Check out at YouTube (http://www.youtube.com/watch?v=oUx9a4g0lJ0)

Problem solved! =)

Thanks for reading!

Cheers,
Gary

flingster
03-08-2010, 08:37 PM
nice...thanks for the link :beer:

CGTalk Moderation
03-08-2010, 08:37 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.