PDA

View Full Version : Maya question about render layers and compositing


piperpam27
01-19-2010, 05:14 AM
Hey!


I was trying to work with render layers, because my computer could not render the whole image at once. I put different things on different layers, and rendered them out(using Mental Ray within Maya), aaaaand...I ran into the issue of the black matte around the outside of the objects I was rendering. The background color of my image was black, and Mental Ray was simply premultiplying semi-transparent pixels onto it. I scouted about online for a while, and found out that you could turn off 'premultiply' in the framebuffer settings. Great! It worked awesome!!

However, I ran into one more issue. Heres the deal, I'm using a skyglobe (Nurbs Sphere with a ramp applied to it) to light the scene via final gathering. So when I render out an object(we'll pretend it is a tree) on a separate render layer, I still want the final gathering of the skyglobe to affect it, however I don't want to skyglobe to render out at all, because I want only the tree on the render layer to be opaque. So, I turned the primary visibility of the skyglobe off. Perfect, because it still emits light but doesn't show up in the render!

Here's the problem though, it works exactly like that EXCEPT, around the edges of the tree, where there are semi-transparent pixels due to anti-aliasing, it is matting the semi-transparent pixels against the skyglobe!! The skyglobe is invisible other than that, because it's primary visibility is off--it only shows up as a matte against which semi-transparent pixels are premultiplied.

Does anyone know how to fix this? Any/all comments are welcome.

Thanks so much!!

-Pete

CGTalk Moderation
01-19-2010, 05:14 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.