PDA

View Full Version : Blender 2.49 and Ubuntu 9.10


DigitalNeutrinos
11-21-2009, 11:45 PM
Anyone having any problems in ubuntu 9.10??
Blender works and opens but is unusable

WmH
11-22-2009, 01:31 AM
Have you installed hardware driver for your video card?

Assuming no,
The default ubuntu X-win GPU drivers are very generic / low performance and not suitable where high performance 3D is required.


(consult the unbuntu forums for install instructions and procedures)

MooseDog
11-22-2009, 02:06 AM
disable compiz, her and blender just don't get along.

Bao2
11-22-2009, 10:33 AM
Ubuntu 64bits 9.10 here
Blender 2.49b here
Nvidia GeForce 8600 GT, driver from Nvidia version 185
Compiz installed too (Compizconfig settings manager)

No problems. Like a charm. As with 9.04

As a sidenote I did some changes in ubuntu:
- Install de Add/Remove applications (the new Ubuntu Software Center is
annooooooooooooyyyiiiiiiiiiiiiiiiiiiiiiiing). Create a icon launcher in the above panel for it and cry of joy again.

- Fix the automounting of internal disks so you are not asked for password to
mount them each minute or so (I have five internal disks with around three partitions so imagine I have around 15 disks and bored of entering the password). The best way of doing this is:

gksudo gedit /usr/share/polkit-1/actions/org.freedesktop.devicekit.disks.policy

Look for this entry:
<action id="org.freedesktop.devicekit.disks.filesystem-mount-system-internal">
<description>Mount a system-internal device</description>
<description xml:lang="da">Montér en intern enhed</description>
<description xml:lang="de">Eingebautes Gerät einhängen</description>
<message>Authentication is required to mount the device</message>
<message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message>
<message xml:lang="de">Zugriffsrechte werden benötigt um das Gerät einzuhängen</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>no</allow_inactive>
<allow_active>auth_admin_keep</allow_active>
</defaults>
</action>

and change that red line to:
<allow_active>yes</allow_active>

DigitalNeutrinos
11-22-2009, 03:17 PM
disable compiz, her and blender just don't get along.

I might have to do that , because ati drivers are installed and working fine.

dac77
11-22-2009, 08:46 PM
I have Debian and fglrx driver doesn't work with compiz and Blender too good. It is actually unusable. This is known problem and unlikely to be fixed by Amd.

WmH
11-22-2009, 09:45 PM
fglrx is a very low performance driver. That is not an AMD driver (it is an "open source alternative to AMD's (ATI) propritary drivers) you need to DL the linux (Deb) driver from ATI. Be aware, It is not a dead simple configuration task and if you can easily render X86 (X-windows) unusable (you will have to fix from CL) so it is strongly recommended that you consult the forums on ATI driver install How-to's.

dac77
11-22-2009, 11:05 PM
@WmH: I am not sure what are You writing about. Fglrx is official driver from amd site and it is binary only. Maybe You meant radeonhd or avivo driver? But I agree it is slow buggy and limiting.

WmH
11-23-2009, 03:49 AM
Sorry, my bad- I was thinking that the Fglrx was the open source radeon driver and not the Catalyst driver.
To clear up any confusion I might of caused- dac77 is correct- the fglrx uses the proprietary (& high performance) ATI Catalyst driver not the open source one.

CGTalk Moderation
11-23-2009, 03:49 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.