PDA

View Full Version : Toon shading coming out jagged


Shack
11-20-2009, 06:25 PM
For some reason when I render out my Two Color Toon shading, it always comes out very jagged. The difference between the light and dark is very boxy regardless if I smooth the object or not. Is there something I am doing wrong? Here's a pic. Thanks for any help.

Shack
11-23-2009, 04:18 PM
Anyone have any idea? Is it the mesh or can i change the setting to have less of a jagged line?

daddyo
11-23-2009, 10:45 PM
smooth your mesh to see how it affects the jaggies. If it does, then its your mesh.

redforty
11-23-2009, 11:24 PM
You just need to smooth your normals.
Select the geometry, go to the normals menu, and hit 'soften edge'.

Shack
11-24-2009, 02:26 AM
I've already smoothed the Mesh and that doesn't seem to make a difference.

I tried smoothing the normals, but nothing changed. I even tried a new file, made a shape and smoothed the normals, it still didn't change the render image. Is there a setting somewhere to control how much it smooths?

daddyo
11-24-2009, 10:35 PM
what else have you tried?

Tweaks on the shader? I am using the same shader right now and getting a smooth finish, so I suspect there is something about your form that is not right.

Shack
11-25-2009, 12:46 AM
Here is a screen of my Vector Settings. The Render Optimizations is set to Safe.

I thought it might have been my mesh but I made a circle , smoothed it and it still came out with the same jaggedness. So it's got to be my settings. Can you post yours? I might have switched something by accident.

phix314
11-25-2009, 01:14 AM
Is it your light? Do you have dmap shadows at all? I've never come across this before..

Shack
11-25-2009, 01:29 AM
I don't know. Even when I try to add different types of light nothing changes (including the brightness).

EDIT: Wow I may be a complete idiot. I am using the Maya Vector, not the Toon Tab. I tried out the Toon Tab and it doesn't have that jaggedness now. Is this my problem? If I want to create something that appears "cartoony" should I be using the Maya Vector, the Toon tab, or both?

ph2003
11-25-2009, 12:29 PM
i have the same problems too... im using toon shading with mr renderer.

for my case, the "jagged edge" not always shows up. when it does, i do a shadow pass and comp it at post.

hope it helps.

CGTalk Moderation
11-25-2009, 12:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.