PDA

View Full Version : p_shadow trubble


orre
11-12-2009, 01:18 PM
Hello!

I'm having some serious trouble with shadow passes in maya 2009. I'm using the mia_material so i assume the standard render passes workflow won't work.

Now I try to use Puppet's p_shadow shader to render out a shadow pass. But I can't get it to work. Everything looks fine in render preview but when I try to batch render all I get is en empty tif-file. Whats wrong?

orre
11-12-2009, 02:27 PM
Ok, it seems that I am missing something fundamental. Since I cant even save the results from my maya render view. All I get is an empty document in Photoshop. No info in any channels. Makes no sense, since render view displays an image in rgb-mode???

prazilukJazz
11-14-2009, 09:23 AM
Hello!

I'm having some serious trouble with shadow passes in maya 2009. I'm using the mia_material so i assume the standard render passes workflow won't work.

Now I try to use Puppet's p_shadow shader to render out a shadow pass. But I can't get it to work. Everything looks fine in render preview but when I try to batch render all I get is en empty tif-file. Whats wrong?

Not sure about 2009 but in 2010 there is a bug where few mray shaders (p_shadow included) break batch render if you have hidden lights (works fine from ui or batch in ui).

Sollution is to drag the transforms of the lights you want to use to p_shadow lights[] attribute or have a mel script do it for you.

CGTalk Moderation
11-14-2009, 09:23 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.