PDA

View Full Version : Mia material refractions


ruddiger52
11-10-2009, 01:04 AM
For some reason I can't get the mia material's refractions to look as good as a regular blinn material's refractions. See the attached images. The mia refractions seem to have much darker areas that look unnatural. Attached also are screens of my mia material settings and render settings. Raising the settings do not seem to make much of a difference.

Anyone else notice this?

Thanks for any advice!

TaKIKO
11-10-2009, 04:30 AM
First thing I would do is change you raytracing options. 10,40,50 is unreasonably too high. Have you tried lowering the IOR? 1.5 is pretty refractive, you may wanna try something lower. I really don't think headlights are really that refractive. You may wanna try using the thin walled option instead of solid because I think the distortion your seeing would come come from using a bump and having a highly reflective mirror surface where the bulb surrounding would be.

http://cdn-write.demandstudios.com/upload//2000/600/30/7/52637.jpg


http://www.faqs.org/photo-dict/photofiles/list/2233/2918car_headlight.jpg
http://www.lubemobile.com.au/SiteMedia/w3svc621/Uploads/Images/headlight.jpg

ruddiger52
11-10-2009, 05:37 PM
If I lower the IOR then I lose the ridges that are modeled into the lens, they just become transparent. Also I usually render with my settings at 10 10 20 but i figured id try higher to get it to work. The IOR is the same for both materials used in the examples. Just wondering why one looks better.

InfernalDarkness
11-10-2009, 08:53 PM
Glass is 1.53 (standard, clear, clean glass), so lowering your IOR isn't the way to go. Water being ~1.33, the closer you get to that number, the less glass-like it's going to look. I'd suggest raising the IOR to maybe 1.6 and see how that looks, in conjunction with the following...

Your raytrace settings should be much lower though, I concur. 10/10/20 at the most.

I think what you're seeing in your Blinn is a LOT of specularity, and not a lot of raytraced reflections/refractions. Also, in your mia_material, you have "Transparent Shadow" checked, instead of refractive caustic. Your lights should be set up accordingly, too: photons/GI/caustics, especially caustics if you want it to look physically accurate.

You're on the right track, though. Keep going!

ruddiger52
11-10-2009, 09:25 PM
Sorry i should have specified. What is seen in the render is solely from reflections/refractions of an IBL Hdri. There are no lights in the scene and no default light either. I will try the refractive caustics.

royg
11-11-2009, 02:08 AM
Jeez, no one seems to be listening to you so I'll repeat it: the IOR is the SAME for both materials!!! For the purposes of figuring out why they render differently, its completely irrelevant what that number actually is so long as it's the same! Leave it at 1.5 for both.

Assuming that the reason for this thread it to problem-solve and diagnose why there is a difference between the two materials:

Have you tried setting the mia back to "thin-walled"? It would be useful to compare the blinn settings with the mia settings (as best as possible - mia doesn't have a "specularity" setting that blinn does). I assume a blinn material would be a fairly simple material, i.e. would only have "thin-walled" and "transparent shadow" as its calculation for refractions, so there's no point in setting the mia to refractive caustic. This will then require you to fire photons, which you didn't have to do for the blinn version, did you?

Firing photons / changing IOR / changing raytrace settings etc isn't going to help diagnose what's causing the difference, if that's our goal.

royter
11-11-2009, 05:01 AM
your images don't show well how your toplight is built.
anyways you have to set the IOR to 40 ,50 or 60 specially if you are using fresnel reflection, this together with a rich contrasted IBL is what you need to simulate a shiny metallic with the mia material. As for the glass parts keep them "solid".

tostao_wayne
11-11-2009, 03:35 PM
it seems like if the glass throws an opaque shadow, have you pluged the same mia_material into the shadow shader slot of the Shading group??

if yes, try setting the refelective color to more than 1, probably 1,2 and uncheck the "skip reflecion on inside" under the avanced reflection tab.

Keep the refractions as solid.

ruddiger52
11-11-2009, 06:24 PM
First of all thanks for all the input. Royg is right to note that the purpose of the thread is to diagnose why the shaders look different, not so much to solve a problem for me. I am curious because I know the mia material is supposed to be the best option for creating physically accurate glass,metal,etc. I have had multiple automotive photographers take a look at the sample and they all pick the blinn as looking more accurate and nice. So this is basically me doing some exploration. For my purposes either result would probably be sufficient. In the end go with whatever looks best right?

Just to reiterate, there are NO lights in the scene, so no spec or shadows on either material. This is purely reflection/refraction from an hdri. I have tried thin walled and it doesn't look right. The model in the shot is cad converted from engineering data that was used to build this car. So the material settings should be accurate for polycarbonate plastic which has an IOR of around 1.585.

Also my render settings need to be 10 20 30. I have raised the max trace of the refractions on the mia material to 20 and the "max trace depth" in the render settings is the limit of the sum of the reflections and refractions.

tostao_wayne, unchecking skip inside reflections did add some detail but it destroyed my render times. They increased like 10 times. So given this result I decided to take reflections out of the equation for now.

In the attached images the clear lens in question has reflections turned off for both materials. The settings for the materials are shown. Again there are no lights or shadows or spec in the scene. It seems to me that the difference is definitely in how the materials handle the refractions.

royg
11-11-2009, 08:13 PM
*** EDIT: Doofus post ;)

kuschel33
11-11-2009, 08:31 PM
a nice workaround we found out is rendering your lights without any shadow at all.
afterwards use a dirt map without the glas to darken the details...

CGTalk Moderation
11-11-2009, 08:31 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.