PDA

View Full Version : p_megaTK_pass p_megaTK questions


vicmarines
10-19-2009, 04:37 PM
hi all

I am having some problems to set up passes using this puppets shaders

I have followed the tutorials on how to set up

When I create the p_megaTK shader and it has its own SG node should I disconnect
this and connect let say my BLINN SG node to the p_megaTK shader or is this not neccesary todo it?

to TEST:
I did a disconnect and connection as above
I create a poly cube and assigned the p_megaTK_pass to it and set to IFF render as 32 bits

for some of the passes I have an IFF error that could not be created

in the MAYA render view I tried to open the files created by the p_megaTK_pass but it can not,is this a limitation of the viwer?

hope someone can share a basic SCENE using this 2 shaders

FrizzleFry0
10-19-2009, 04:43 PM
I haven't used the megaTK shader, so I can't help with that, however IFF files do not support 32bit. Try setting it to TIF.

Puppet|
10-19-2009, 06:23 PM
to FrizzleFry0:
Maya IFF support 32 bit float.

to vmarines:
What error?
You just need assign shader to objects.

vicmarines
10-19-2009, 09:10 PM
Hi Puppet

I had a wrong connection on the p_megaTK_passs (geomwtry shader) now that is fixed and I does not have any errors on script editor for the generations of IFF 32bit files.

quick questions:
does the next shading network connection is correct? when I create a MEGA_TK shader it has its own MEGATK1SG node should I remove this and leave that connected to the BLINN SG node or does not matter

http://www.azulrender.com/3dart/shading%20network.jpg


when I render passes my goal is to have shadows separate from the hair onto the geometry

shadow pass
diffuse oclussion pass
ambient oclussion pass

also sharing my setup and the resulting images that seems is not what I expect to have, something I am doing wrong

http://www.azulrender.com/3dart/p_megaTK%20shader.jpg





http://www.azulrender.com/3dart/hairSG%20node.jpg


http://www.azulrender.com/3dart/mib_oclussion.jpg


http://www.azulrender.com/3dart/p_hairTK.jpg


images IFF rendered,
is it normal in 32 bits to have this jagged output?
is it normal not to have alpha channels for the passes?

shadow pass I get
http://www.azulrender.com/3dart/TK%20pass%20shadow%20pass.jpg


amb_oclussion pass

http://www.azulrender.com/3dart/tk_pass%20anmb%20occlussion.jpg


Diffuse Oclussion pass

http://www.azulrender.com/3dart/tk_pass%20difuse%20occlussion.jpg


as you can see the passes I get seems odd I am sure I am doing some wrong, could I have a example scene from you

thanks Pavel

Puppet|
10-20-2009, 08:57 AM
Yes, you may delete p_MegaTK SG node if you want

Why spread is so low?

Please share example scene. I'll view it.

vicmarines
10-20-2009, 08:40 PM
Puppet I attach the scene,

I adjusted the P_spotTK light shader so now I can have depthmap hair shadows on to the surface from maya lights, but I still having problems with the OCLUSSION passes

thanks for keeping an eye on the next scene (http://www.azulrender.com/3dart/p_shaders.mb)
in 3 files I had to split it

vicmarines
10-20-2009, 08:44 PM
Puppet

ups !! there is no more space for the third file, damnt

can I send the third part to an e-mail?

thanks in advance

vicmarines
10-21-2009, 01:34 AM
I sent u an e-mail with the scene file

thanks for your support

-Vic

Puppet|
10-21-2009, 10:48 AM
Sorry, I have no Shave&Haircut and could not render your scene.
I have created Maya Fur instead Shave in your scene.

Comments to your scene...
1. Raytrace was disabled in Render Settings. For Occlusion it should be enabled. I suppose it's common problem for your scene.
2. Occlusion Spread in mib_amb_occlusion is to high 10. By default 0.8 (radian).
3. Occlusion Spread in p_MegaTK and p_HairTK is to low 10. by default 88 (degree).
4. spotLight4 have to high Detail Shadowmap Samples 32. Usually 2-8 is enough. In most cases 3-4.
5. Effect to Ambient is 0.5. Possible you should set it to 1.0 for get 100% occlusion pass.
6. Diffuse Root is black. It's not recommended to set Diffuse Color to 0. Because some artifacts may appear in passes. Better set it to 0.002-0.01.

I can see in your scene that black hair with color variation produce colored (or negative) pixels in occlusion pass. It's p_HairTK bug. I'll fix it.

32bit IFF is not displayed correctly in Maya fcheck, by looks fine in Nuke.

Here is fixed scene:
http://www.puppet.tfdv.com/p_shaders1.zip

vicmarines
10-21-2009, 09:49 PM
Pavel

Thanks very much for your support.....and help me

so Raytrace enable for Oclussion, I did not think about it

I will do a render tonight with your recomendation settings and will use NUKE to display and composite

bytheway I see your shaders work fine for me with scanline or rasterizer, and also layering those with maya render layers

thanks I will keepin touch to see new updates on your shaders

RGARDS

vicmarines
10-21-2009, 09:52 PM
ahhh..... hope the scene you fix and attach serve as a guide for more budys here at this forum

vicmarines
10-22-2009, 09:39 PM
Puppet

Is there a way to have hair using p_hairTK shader rendered with its own ALPHA channel,
without to turn to 0 the OPACITY in the shader?

since that will cause front hair and back hair to show

Rgards

Puppet|
10-23-2009, 12:35 PM
Do you need visibility control or just mask?

If mask and you are using my passes, you may use any SpecialC channel.
If visibility, you may use Render Stats attributes.

vicmarines
10-26-2009, 06:34 PM
yes....

I need to mask the hair from any other geometry, and using the special passes in ur shaders

will do the trick

in this case I will add p_hairTK shader with its own special pass with a white color
so in this way I will not mess with my scalp geometry using the p_megaTK shader and their OPACITY since this will cause not a ver proper masking since masking will include some parts
of the hair that should be ocluded by the scalp geometry itself

I will post some examples....of the results

Thanks very much

Jaylee81
01-11-2010, 09:49 AM
yes....

I need to mask the hair from any other geometry, and using the special passes in ur shaders

will do the trick

in this case I will add p_hairTK shader with its own special pass with a white color
so in this way I will not mess with my scalp geometry using the p_megaTK shader and their OPACITY since this will cause not a ver proper masking since masking will include some parts
of the hair that should be ocluded by the scalp geometry itself

I will post some examples....of the results

Thanks very much


Did this work out for you? If so maybe you could post it as you mentioned, I know I'd like to see them =)

DaevFinn
08-13-2010, 10:42 PM
Hi Pavel,

First I wanted to say I hope things are going okay in Moscow with the fires burning all around.

If you have a chance I wanted to know if you can comment on what you mean when you say in your tutorial for assigning p_HairTk to the shaveDisplay node.

To do this I have gone to the Flags section, where it says Geometry Shader. I enabled Geometry Shader and then dropped the p_HairTK shader into the Geometry Shader line.

I have also gone to the shave hair and turned "Override Geom Shader" off.

If I understand this correctly this is what needs to happen to make the shader work but with Maya 2011 I have not had success yet.

On another note do people in Moscow feel that these fires are directly related to global warming? Here in the states there has been a struggle to get the government to commit to combating what we see as more warning signs of things to come. Hurricane Katrina - Pakistan floods - Russian Fires.

Keep safe.

thanks
Daev
daev.finn@mac.com

Puppet|
08-14-2010, 06:04 AM
Sorry, I have no Shave now, but as I know...
You should assign p_HairTK as any another shader (like Lambert to pSphere, just Assign from Hypershade).
And turn "Override Geom Shader" off.

I suppose it's better to ask someone else that are using Shave.

P.S. It's ok in Moscow now... Just like California summer 2007

DaevFinn
08-15-2010, 04:35 AM
Pavel,

This simplified things greatly, I was trying to be too complex. Thanks.

-Daev

bigg71
07-15-2011, 06:13 PM
Hello all,
I am new here and, of course, I ran into a wall.
I looked over a lot of forums, and still is not very clear to me: can I render a separate pass only for the shadows of the hair?
I am using shave and haircut with HairTK. Everything looks a lot better and works fine, but since I want to render the body with Vray, I would need a separate pass for hair (which I can do), and another one for shadows of the hair only.

Can anyone help?
I hope there's still somebody around here :)

koshey
08-18-2011, 01:30 AM
Oh god. Yeah i need help with that too. Preferably in the most "for dummies" format possible. I am using shave & haircut 5.5 + mental ray. Can't figure out how to do hair shaodw separately. The best i've came up with is render a pass with hair shadows off and another pass with hair shadows on and then use 'difference' in photoshop to get just hair shadows from thos two renders.

CGTalk Moderation
08-18-2011, 01:30 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.