PDA

View Full Version : Multiple maps attached to ambient occlusion preset


LoudNoises
10-19-2009, 02:07 PM
I am currently trying to render an ambient occlusion pass using the preset under a seperate render layer. I have generated occulsion maps and displacement maps from zbrush. As a start I am trying to work out how I attach different occlusion and displacement maps to the correct geometry (each piece of geometry has a seperate uvs set all in 0-1 region) under the same shader node. I have tried seperate shaders for each piece of geometry but the occlusion overide seems to only allow one shader to be used. I have used triple switch nodes to apply different colour maps to different uvs sets under the same shader node but I cannot seem to replicate this using the occlusion preset. Now I am probably being stupid but if anyone knows how to solve this issue It would much appreciated.
Thanks.

FrizzleFry0
10-19-2009, 02:32 PM
When you make a new render layer, don't right click on the layer and do material override because that assumes that whatever material you select you want on everything in the scene. So you're probably overwriting your other shaders every time you do that. Create a new layer without the shader override. Select the geometry pieces you want for one of the shaders, and inside of the hypershade right click on the shader and do apply material. There's a create layer override apply too that you could try out, but the regular one seems to understand layer-specific connections anyway.

LoudNoises
10-19-2009, 02:58 PM
Many thanks, that seems to have solved the problem.

CGTalk Moderation
10-19-2009, 02:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.