PDA

View Full Version : Smooth lines between meshes?


Claudelee
09-15-2009, 03:55 PM
Hey guys,

I'm encountering a problem while modelling something in Maya!
I created to polygons mesh That I combined and merged together. However, where the two meshes had been merged, I don't have a smooth line. How can I resolve that?

Thanks for your help!

conio
09-15-2009, 03:59 PM
Not sure, but did you weld the vertices? I think just merging two meshes does not weld the vertices. Take a look if there are two vertices lying on top of each other.... Could also be an an hard edge in the sub-div I think... but I am not very familiar in modeling with mayas sub-divs....

Claudelee
09-15-2009, 04:48 PM
I actually merged the vertices together.. So it's not that. What do you mean by an hard edge in the sub-div?

I got the same problem on an other part of my mesh. I merged the same way fingers to a hand. One finger is OK, the other one has the same weird edge.. :s

Piflik
09-15-2009, 05:00 PM
The issue are the Vertex Normals.

Edit Polygons -> Normals -> Soften/Harden

Edit: Oh...just saw that these are subdivided Meshes...look up 'crease'.

Claudelee
09-15-2009, 05:42 PM
Thanks for your help Piflik,
But I don't see any difference after the soften operation :s
How I am supposed to do exactly? Sorry, I'm new to Maya and learning by myself.

Piflik
09-15-2009, 05:56 PM
Yeah sorry...I just realized that these are subdevided meshes...have a look at the 'crease' option and also check, if you possibly have two edgeloops on top of each other.

sumeetkaur
09-15-2009, 06:54 PM
Hey merge the edges.

Claudelee
09-15-2009, 07:13 PM
Nop, doesn't seem to be an edge loop problem. And the crease option?
Here's my .mb file if someone could have a look at it.. It would nice :)

sumeetkaur
09-16-2009, 12:54 AM
I checked your file. The problem is in your model's FACE NORMALS.

The Normals(the direction of the faces) of the legs of your model are going in the direction outside the mesh(which is correct)
But the Normals of the rest of the body of your model are facing opposite direction, that is inside the mesh( wrong direction).

select your model. press F8.
go to Display- polygons-Face normals.
Now your model would show normal lines on it(green lines)
Hit F11
select faces of rest of the body(excluding legs.its normals are perfect)
go to Normals and hit Reverse.
aaafter you have corrected all the normals of the body press F8
go to Display -polygons- Face Normals.(to hide normal lines)
A geometry should always have Normals facing the same direction.:)

conio
09-16-2009, 09:38 AM
Yeah, thats why I normally always model with Backface Cull ON. In Maya the standard display is without Backface Cull which leads to such issues. At least there could be a different color for the backfaces in Maya, so you could see which side is actually Front/Back...

Claudelee
09-16-2009, 09:39 AM
Thanks sumeetkaur for your precise explanations, that really helped! :applause:
But I'm confused.. How did you know that the body faces normals were upside down? Why the body and not the legs?
Oh just.. I also tried to apply your method on the toe. It kind of worked, it's not as strong as it was, but I still have a weird line on it? :curious:

sumeetkaur
09-16-2009, 05:04 PM
You are welcome.

About your question that how did I know that Face Normals are not perfect. The answer is that when a problem like in your model exists, the first thing we have to do is check the Face Normals of the mesh (by going to Display-Polygons-Face Normals)

As I told you a models Face Normals should always be in same direction that is going outside the mesh(which in your case were correct only in the leg.the normals{green lines} of the rest of the body were going inside)

Even if you want to take your model to ZBrush first thing you have to do is check whether its Face Normals are perfect or not.

Well your new file in not opening in my machine.send it again.

check the vertices are merged properly at toe and try to merge the edges.:)

Claudelee
09-16-2009, 05:52 PM
I just cheked once more the face normals.. It's so dense! I see that some parts are still in the wrong way but can't say exactly which one.

For the toe, I had to delete a vertex to tide a bit the mess. It's better but not yet resolved.
If you look under the feet, where the two toes are diverging, there's still a vertex linked to another vertex outside of the foot. I don't know how to solve that..

Hope you will be able to help me on that :)

sumeetkaur
09-16-2009, 06:15 PM
I dont know why, my winrar utility programme is unable to extract your file.

sumeetkaur
09-16-2009, 06:22 PM
this is the error............

Claudelee
09-16-2009, 06:26 PM
Mmh.. I'm compressing it on a Mac, It might be that. I'll do it on windows. Will be right back!

Claudelee
09-16-2009, 08:08 PM
All right.. It took longer than expected but here's the windows zipped file! Tell me if you can read this one :)

(Nearly at the end of my allowed space storage :s I would have to delete older files to gain more room?)

sumeetkaur
09-16-2009, 08:30 PM
yes ,I can read this file now. But plz give mesome time to see whether I can solve your problem or not;)

Claudelee
09-16-2009, 09:02 PM
No problem :)
Once again, thanks for your help and your time!

sumeetkaur
09-16-2009, 10:20 PM
Hi! you have overlapping faces inside your toe mesh(which you cant see from the outside of the mesh)which is forming a hard line outside your mesh.

To understand things better, press F11.Delete the whole mesh except the toe part.
Peep inside your toe geometry.You would see some extra faces at the problem area. These faces you cant see from outside of the mesh.
Delete these faces
Merge the vertices now . you would have alot of unmerged vertices over there.
And you have really bad normals on your toe. It would take you some time to correct them.

I dont use Max but I have seen one of my friend adjusting really bad normals like this by attaching the geometry with a new geometry, so that the geometry with bad normals can take the normal properties of the new mesh(hence the old geometry gets fresh new normals).If you have used max earlier try this in Maya.I dont know how it could be done.

Moreover in Max there is a way to increase and decrease the size of normal lines.I dont know if thats possible in Maya.

I have posted the render of your file on which I worked and did a bit of correction.You wont see the hard line in this render.but a lot has to be done on the toe yet regarding normals.;)

sumeetkaur
09-16-2009, 10:39 PM
To make you understand things better following faces are to be deleted.

Claudelee
09-17-2009, 08:58 AM
Hi!
All right, I deleted some faces and saw those inside faces! Deleted them and rebuild the topology. I found the option that let you change the size of the Face normals. Much easier to see that all the toe was upside down. I reversed it and now it's perfect! :thumbsup:

Thanks to you I discovered some useful tips in Maya!! :D
It's a pleasure to learn those kind of softwares in a community like that!

I'll see you soon on the forum! :wavey:

sumeetkaur
09-17-2009, 08:23 PM
How did you increase and decrease the size of normal lines? plz share it with me on this thread.;)

sumeetkaur
09-17-2009, 08:30 PM
Forget it I found out. Its done by Normal Size option in Display-polygons-Normal Size;)

Kithlak
09-18-2009, 05:12 PM
Have you deleted the polygons inside the merge?

sumeetkaur
09-19-2009, 01:40 AM
yes the inside faces where the two meshes merged were deleted .

Claudelee
09-19-2009, 10:06 AM
Hehehe.. Yep :)

GrogMcGee
09-19-2009, 10:22 PM
I extracted the toe so you can see what's wrong:

http://lh6.ggpht.com/_kyuBN4GsaYo/SrVY94eFy_I/AAAAAAAADRk/RI6w7dwOo40/s800/Fullscreen-capture-19092009.jpg

delete the selected faces; you'll also need to reverse the normals (easiest way would be select the model and choose conform from the normals menu).

sumeetkaur
09-20-2009, 03:13 PM
great trick:beer:

Claudelee
09-21-2009, 03:38 PM
you'll also need to reverse the normals (easiest way would be select the model and choose conform from the normals menu).

Good to know! Thanks! :thumbsup:

Doner
09-24-2009, 09:34 PM
display normals is messy. I can't tell jack squat when looking at them. I would recommend looking under the Lighting menu and turning two sided lighting off. Every reverse normal poly will display as flat black, making it easy to see which way they are flipped at a glance. If your menu isn't in the viewport window, you can turn it on in preferences>interface>show menu bar (in panels),
A fast way to fix it without much effort is choose your model and choose Normals>Conform which will point all normals on the mesh one way or the other. if they are now ALL black choose normals>reverse

CGTalk Moderation
09-24-2009, 09:34 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.