PDA

View Full Version : Update a plugin - error


Davide-sd
09-06-2009, 12:45 PM
Hi all,
i'm new here, and i hope someone could help me.
I need to update the WarpTexture plugin (http://www.footools.com/3dsmax_plugins.html) to use it in 3ds max 2009 x64. I've compiled the 32bit with visual studio, and it's ok, but i can't compile the 64bit version because i've got this error: "fatal error LNK1112: module machine type 'X86' conflicts with target machine type 'x64' core.lib WarpTexture".
I've checked all the options, and i don't know why it happens. This is the first time i've tryed to update a plugin, so i need some help.

guruware
09-06-2009, 03:02 PM
a) in linker options - advanced: set "Target Machine" to MachineX64 (/MACHINE:X64)
b) in linker options - general: check your "Additional Library Directories", you have to link the x64 libs of the sdk, so it should read like "..\..\maxsdk\x64\lib"

guruware

Davide-sd
09-06-2009, 03:49 PM
Thanks really really much guruware.
It works! :D

maxplugins
09-06-2009, 07:46 PM
You can download WarpTexture for all newer versions of Max, including 64-bit versions, at www.maxplugins.de

Dave

Davide-sd
09-06-2009, 10:12 PM
Thanks guruware, it works!
Thanks maxplugins, it'll be the first site i'll check next time! :)

CGTalk Moderation
09-06-2009, 10:12 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.