PDA

View Full Version : physical light shader and area light question


royter
08-04-2009, 09:48 PM
i don't want my area light to be visible in reflections and i don't want it to emit specular light.
so the "visible" options (in the MR section) is checked on and the visibility is set to 0.
this works fine. But when i attach a physical light shader to my light, the square area light reappears in reflections even if visibility is set to 0.

now i can check off "visible" but then the area light will emit specular no matter what ( even if i turn off "emit specular")

any ideas?

SirRender
08-05-2009, 12:27 AM
From my understanding, the physical light shader suppresses the regular Maya light control check boxes for diffuse or specular only. The problem is the light shader, it will not allow it, unless you break the connection, and not use it. At least, that's what I was taught.

Or you can try and do it in passes, where you eliminate the specular from the shader, do a diffuse pass and then a specular pass and comp them together.

royter
08-05-2009, 04:12 PM
From my understanding, the physical light shader suppresses the regular Maya light control check boxes for diffuse or specular only. The problem is the light shader, it will not allow it, unless you break the connection, and not use it. At least, that's what I was taught.

Or you can try and do it in passes, where you eliminate the specular from the shader, do a diffuse pass and then a specular pass and comp them together.

actually the sahder is awahare if the "visible" option is OFF or ON but the problem is when it's set to ON even if you turn down visibility to 0, it will still be visible.
(and if you uncheck "visible" then the light will be emiting splecular light no matter what)

CGTalk Moderation
08-05-2009, 04:12 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.