PDA

View Full Version : 3delight motion blur on ShaveHair


StefanAlbertz
07-06-2009, 02:57 PM
Ive got some problems with motion blur and shave & a haircut using 3delight on Maya - and want to share and ask if someone also had those problems:

Ive a hair-shot, where i didnt animate the hair itself but (only) the frizz and kink parameters. The hair should first be unruly and then smooth, thats it. Now after i rendered the sequence i found that there is need for motion blur. After turning it on, there is absolutely no difference: whatever parameter i change, there is no blur. Ive used geoattributes to override the motion blur settings, ive cranked up the samples on all three (translation, camera, deformation) - no change at all.

My wild guess is, that something within the shaveNode is not translated to 3delight. It seems, that the kink and other options may not be translated on the motion blur stepping at rendertime.

Has anyone an idea how i could solve this problem?
Thanks in advance!
Stefan

jupiterjazz
07-07-2009, 10:37 AM
Ive got some problems with motion blur and shave & a haircut using 3delight on Maya - and want to share and ask if someone also had those problems:

Ive a hair-shot, where i didnt animate the hair itself but (only) the frizz and kink parameters. The hair should first be unruly and then smooth, thats it. Now after i rendered the sequence i found that there is need for motion blur. After turning it on, there is absolutely no difference: whatever parameter i change, there is no blur. Ive used geoattributes to override the motion blur settings, ive cranked up the samples on all three (translation, camera, deformation) - no change at all.

My wild guess is, that something within the shaveNode is not translated to 3delight. It seems, that the kink and other options may not be translated on the motion blur stepping at rendertime.

Has anyone an idea how i could solve this problem?
Thanks in advance!
Stefan

Try to:
- save RIB from delight and check in the rib scene if motion vectors are present. If not report to DNA and use shaveWriteRib making sure in your rib motion vectors are present. Just run MEL: help shaveWriteRib to see the flags for exporting, I suggest you to use -isg (Ignore Shave Globals) to not mess up with the shave UI.


p

StefanAlbertz
07-08-2009, 12:03 PM
Thanks paolo. I checked the RIB Files (first time i ever wrote those to disc) and didnt find motionblur in the scenes where i had no blur in renderview. But the problem was found and solved through workaround via DNAs board:

the inner attributes of Shave and a Haircut (like kink + frizz + animate frizz) are not interpolated when keyframed. I turned off the timeline snapping and scrubbed through the frames. Result: you can clearly see the popping each time you enter a new frame number ...
The workaround: just use 2 timesamples centered on frame, so that 3deligh sees the frame before and the current frame. This solves the problem for this shot - but Joe Alter should fix the plugin.

jupiterjazz
07-12-2009, 08:58 AM
Thanks paolo. I checked the RIB Files (first time i ever wrote those to disc) and didnt find motionblur in the scenes where i had no blur in renderview. But the problem was found and solved through workaround via DNAs board:

the inner attributes of Shave and a Haircut (like kink + frizz + animate frizz) are not interpolated when keyframed. I turned off the timeline snapping and scrubbed through the frames. Result: you can clearly see the popping each time you enter a new frame number ...
The workaround: just use 2 timesamples centered on frame, so that 3deligh sees the frame before and the current frame. This solves the problem for this shot - but Joe Alter should fix the plugin.

Yes it should be fixed within Shave. IMHO also linking to 3delight API rather than PRMan one would be a good idea, which would allow to provide shaveWriteRib on all platform (in your case win64), and possibly OSS the RIB exporter itself.

p

CGTalk Moderation
07-12-2009, 08:58 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.