PDA

View Full Version : Maya MR Shave and Hair rendering with Displacements


harshdesign
06-30-2009, 05:40 AM
Hey guys. I'm having few problems with my production pipeline in Maya MR with Shave & Haircut.
I'm rendering a character's face in Maya2009 MR with SSS fast skin shader. With Subdividion Approximation using 32bit openEXR Displacement map and Shave & Haircut V5.0V59.

1. With displacement applied to head geometry, the Shave doesn;t render, and the maya scene crashes with fatal error. When i take off the displacement, the hair renders fine with SSS.

2. Im using Hair Buffer, and its giving me an edge(alpha edge) along the surface where the geometry meets hair. Tried various options and can't seem to get rid of it. I do not want to render hair as Primitive or geo as they take years to render, and buffer is giving me the quality i want.

3. What would be the best way to render hair in different passes? so that i have head render with SSS as one pass, hair as saparate pass, and shadow as saparate pass?

I would really appreciate any help as im looking to find a clean pipeline for what i want to achieve.

Thanks

mechaniac
07-05-2009, 08:31 AM
i was rendering shave and a haircut on characters with MR and got fine results. (but only after having 2 horrible weeks with render errors and crashes all over, but I learned quite a lot in this time)
what I learned:
dont use buffer mode in MR as only maya render is supported
for mental ray use hair primitives, gives great results and has low render times. even if I set the hair to quality low and 2D post, its very nice quality and renders about the same time as buffer.
use rasterizer (rapid motion) primary renderer

I didnt render hair in separate passes, but only separate lights (rendering each light of the scene extra and composit with screen mode)

rendering hair passes is only supported in buffer mode, so you could set up a scene where you render in Maya Software and buffer mode for only the hair. Apply a use background (or plain white) material to your character so you get only the sadow on it.

I cant think of a reason why the scene would crash with the displacement, but I guess the reason lies somewhere else. Post a shot of your scene and settings here, maybe i can help.

CGTalk Moderation
07-05-2009, 08:31 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.