PDA

View Full Version : Area Shadow Problem


neofg
06-05-2009, 10:28 AM
Hi all! I have a little problem with shadows...
I put an AREA Shadow out from window, the result with Mental ray is a segmented shadow on the wall.
When I make it softer then I have a lot of noise. 2 problems! 2 damned problems...
Can someone help me? I think it's simple but I can't go out from this...

Thanks...
I attached a preview...

neofg
06-08-2009, 08:23 AM
That's another test...It's full of noise in the shadows...

FrizzleFry0
06-08-2009, 09:03 PM
Are you using a regular Maya area light with depth map shadows? If so, increase the map size.

neofg
06-09-2009, 08:39 AM
Hi and Thanks.
No, It's an AREA LIGHT with Mental Ray's "Regular Shadow Map"
I tried to change aliasing settings in the MR tab, samples in the "shadow map" options but nothing...
If you look at the wall strange lines appear on it.
A mistery!

cbamber85
06-09-2009, 05:02 PM
Switch to ray traced shadows, increase both shadow rays and high samples. Make sure you scale the area light itself to soften the shadows appropriately. If you're getting 'interference' like patterns, try increasing the adaptive sub sampling settings.

Hamburger
06-10-2009, 11:06 AM
i cannot see the problem, however if there are very tiny patterns (on that second image you posted, the very far left of the image) like what I think it is then it's the "bias" option. usually increasing this number gives less accurate shadows but decreases noise. a fine balance and tweaking is necessary.

neofg
06-12-2009, 04:09 PM
Ok, but so I never solve the problem... I change the kind of shadow. I know how use the raytraced shadows...
But here I use the "mental ray area shadows". And all go wrong...

cbamber85
06-12-2009, 04:37 PM
Raytracing shadows is just a different method of calculation, it is irrelevant if you use area, point, spot, etc.

Try setting the High Samples to 24, High Sample Limit to 4 and Low Samples to 8; see how that looks.

neofg
06-23-2009, 09:27 AM
Mmmmh...That look strange cbamber85. I tried your method with samples, but I have the same noise and a 33times more time spending. About Raytraced shadows is obvious that When I abilitate the "Mental ray shadow map overrides" the "raytraced shadows" don't work.
For HamburgerTrain instead, the bias option make my shadows far from objects and work very very bad.
There must to be an option to decrease the noise with that options... :banghead:

cbamber85
06-23-2009, 10:01 AM
How big is your area light compared the scene geometry? If it's massive you'll need more samples and more Shadow Rays. Post pictures of the changes as well.

MAV4d
06-24-2009, 06:30 AM
I "think" hes using a mR area light. Up the sampling in the area light's mr tab to reduce the noise

neofg
06-29-2009, 09:08 AM
I solved the problem with an higher value of "resolution" in the "shadow map overrides".
From 1024 to 3-4000. Just a so simple value...
I hope this will be useful for someone in the future...
Thanks to all for your support...
:thumbsup:

leif3d
06-29-2009, 05:33 PM
Your solution was the suggestion in the first response: "increase the map size."

Too bad it wasn't clear to you, it would have saved you a lot of time :)

Another thing...Make sure you choose a square pixel resolution for you shadow map to avoid any filtering issues. Example: 4096 or 2048.

Sybexmed
09-30-2009, 08:29 PM
Im confused, you said you are using regular shadow maps MR, and now you increased the map size. Does that mean you switch to depth map?

CGTalk Moderation
09-30-2009, 08:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.