PDA

View Full Version : Texture Filtering prob. behind MiaX


romeu
05-28-2009, 10:47 AM
Hi, i have been trying to resolve this with no luck,

it seems like the texture filtering is not working behind a miaX material.
i made 3 exemples to explain the problem:

Maya2008 sp1

Render with no GlassWindow:
http://romeu5000.com.sapo.pt/Test1_NoG.jpg

Render with Glass, shader miaX (glass is a cube, Mia preset GlassThick):
http://romeu5000.com.sapo.pt/Test1_MiaX.jpg

Render with Glass, shader Blinn:
http://romeu5000.com.sapo.pt/Test1_Blinn.jpg

As you can see, with no glass or with a blinn shader the filtering is working, with the MiaX all i get is this blur. the result mantains the same with diferents filters (Off,mipmap 1.0, mipmap 0.1, quadratic).

I also tried with a single polyface (no cube) glass window with the apropriates settings for the miaX (thin) but the results are also the same.

I tried a lot of others things but again with no luck,
if someone came across the same problem and found what going on, please let me know.

thanks,

Romeu

romeu
05-29-2009, 09:44 AM
ok, found what i was doing wrong...

We are working with meter units for some time now, and some units have to be adjusted.
(why meters? well, after some testing we found that, especialy in interior rendering, FG with radius control would work better for animations. why... i which i knew)

for example, in centimeters(maya default units) a texture with mipmap filter of 1.0 is equivalent in meters os a mipmap with filter of 0.1 ...

well i forgot the filter of the bump node, as well as some other procedural nodes that also need to be adjusted.

Maya units.... thats realy an other world...

CGTalk Moderation
05-29-2009, 09:44 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.