PDA

View Full Version : render the object with animated visibility and motion blur is enabled (moved)


alanfish
05-25-2009, 06:05 PM
Hi,

I have got a problem : render the object with animated visibility and motion blur is enabled
( Maya 6.0 + Mtor 6.0 + RPS 12.5 )

I have prepared an image attached with this post.
It shows the animation curve for the visibility of a cube.

Motion Blur : Off
It shows the same result as what the cube is animated in the maya viewport .

Motion Blur : On
At frame 5 and 15, the cube disappear in the render images.

Is there any way to fix it? or Do I miss any step?

Thanks for your kind attention.

alanfish

http://www.geocities.com/alanfishwing/visibility.gif

kjaft
05-26-2009, 07:24 AM
Dude, this is the graphics programming forum. So please place your question somewhere else.

mindsample
05-27-2009, 12:02 PM
even though I dont know why you posted this here - nice presentation with your picture!

in easy terms the motion blur algorithm looks at adjacent frames to determine the amount and direction of the blur. if the object in an adjacent frame has its visibility switched off it probably runs into an interpolation issue.

Seems unnatural, I agree, one would expect some sort of half visible cube but visibility != transparency, i.e. its a binary switch and hence can not hold any values other than 0 or 1. interpolation is mathematically not possible.

Use transparency instead and it should work.

CGTalk Moderation
05-27-2009, 12:02 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.