PDA

View Full Version : How to Assign UV Set to Texture?


EightBit
05-20-2009, 08:39 PM
Hi all:
I've imported some meshes from LW to Maya.
In the Maya version, there are several UV sets - some appear to have several overlapping layers of UV maps, so I'm redoing the UV's.
If a material "fat_mtl" is using a given UV set, say UVSet1, and my new UV's are created on map1, how do I assign map1 to the texture in "fat_mtl"?
Thanks.

EightBit
05-20-2009, 09:13 PM
A bit more info about what I'm trying to figure out:
As mentioned, I've created a new UV map on Map1. The texture is rendering correctly, but the texture doesn't appear in the UV Editor when I have map1 displayed. Even when I choose the texture node from the Texture Menu, it won't display. However, if I choose the original UV Set that was assigned when I converted the file, the UV's are gone (I deleted them), but the texture displays correctly! I've confirmed that in both instances, the same node is selected in the Texture Menu, it simply doesn't display when Map1 is chosen.
:banghead:

EightBit
05-21-2009, 02:53 AM
Another update for anyone interested in this topic:
I've found that the Texture-Centric UV Linking Relationship Editor can be used to determine which texture will be displayed in the UV Editor for each UV map. It appears that this is completely independent of which texture the UV's are being used for.
I don't know if that's the only purpose of Texture-Centric UV Linking.
Also, when I used the Relationship Editor to rename a UV Map, I had to close/reopen the file for the new name to showup in the UV Editor - this appears to be a minor bug.

CGTalk Moderation
05-21-2009, 02:53 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.