PDA

View Full Version : Fusion, Vray, Physical camera, LWF problem


Sinew
05-19-2009, 08:36 PM
Hey all,

I have a querry. I'm trying to composite a scene using Fusion.

I have made a quick test scene, this is rendered in 3DS Max, Vray 1.5, using a Vray Physical Camera, and Linear Work Flow.

As you can see from my screen grab of Fusion, the composite using vray elements doesnt look like the control (straight render, on the left).

When I turn off LWF and just use straight gamma of 1, my composite works fine, so I doubt there's a problem there. But as soon as I try working in LWF, I hit this problem.
I must have tried numerous renders turning off just about every setting I can think of, but I still dont get the correct results.

In this composite, colour correction is unticked in the diffuse element, but is ticked in the lighting, gi and background elements.

Does anyone have any ideas?

Thanks, Dean

Sinew
05-27-2009, 08:31 AM
Anyone please?

Seraph135
06-04-2009, 06:54 PM
There are a lot of factors here so its hard to say without looking at your file and passes individually.

Right away it looks like you've got some incorrect gamma settings for your buffers. Open a brand new scene and check what the default gamma settings are for each buffer you want to render. Make sure that your actual scene file is set the same way.

If I were you I would not use Max's gamma and LUT settings. Your changing the display gamma which doesn't cause any harm, but I find it to be less accurate than using the Vray Frame buffer which allows you to use a real sRGB curve and you can toggle it on and off easily to see the linear frame if you want. I also don't recommend using the input gamma for your texture maps since this changes ALL of your texture maps anywhere you put them, when all you really want to change is the gamma of your diffuse color maps. I recommend using the color correct plugin to apply gamma to your diffuse textures, or turn on Max's gamma settings, but leave everything at 1.0. This will allow you to choose what gamma you want to use to override your texture maps with when you initially choose them in the material editor.

I also notice that in Fusion you have the LUT turned on for the right viewport, but not the left. Maybe its not doing anything, and maybe it is. If your going to be compositing Vray's buffers then I always render linear buffers and then use Fusions LUT with a gamma 2.2 (or an sRGB profile) to see them properly. At the very end of my flow I'll put a gamut node set to sRGB before the saver. That way it saves out with the correct end gamma, but all the compositing happens linear.

Also, in Fusion make sure that in your preferences you are actually allowing at least 16bit float files to be loaded and displayed.

Tim J

Sinew
06-05-2009, 07:33 AM
Thanks Tim, good advice over the input gamma, will give that a go as it makes total sence.

Sorry I guess I should close this topic now as I finally figured it out.

Just for future reference (if anyone's interested) this is how to do it -

First set gamma / colour mapping to the traditional 2.2 LWF setup.

Then, when setting up the scene and doing all test renders, use the vray frame buffer as usual, this displays the rgb correctly.

Then when you want to render you image using render elements, turn off vray frame buffer, turn on render elements, and tick Don't affect colours (adaption only). The frame buffer will look incorrect but don't worry.

Now when compositing the elements back together in Fusion, do so as usual, then at the end add a Colour Correction node, and simply set the gamma to 2.2!

Simple (I bloody wish!)
Dean

adom86
03-06-2010, 09:19 PM
Thanks Tim, good advice over the input gamma, will give that a go as it makes total sence.

Sorry I guess I should close this topic now as I finally figured it out.

Just for future reference (if anyone's interested) this is how to do it -

First set gamma / colour mapping to the traditional 2.2 LWF setup.

Then, when setting up the scene and doing all test renders, use the vray frame buffer as usual, this displays the rgb correctly.

Then when you want to render you image using render elements, turn off vray frame buffer, turn on render elements, and tick Don't affect colours (adaption only). The frame buffer will look incorrect but don't worry.

Now when compositing the elements back together in Fusion, do so as usual, then at the end add a Colour Correction node, and simply set the gamma to 2.2!

Simple (I bloody wish!)
Dean

Hey buddy good work on finding all that out!

You know when you said 'do so as usual' in fusion. What exactly is that? I have just tried to mimic your screen shot by plugging the GI and Lighting into merge slots which have the multiply blend mode and are both connected to the Diffuse Filter element.

Is that how you do the multiply, just by the blend mode? Yours are actually saying multiply on them, mine still say merge. I have done everything else the same and just always looks crazy as a finished image. Just wondering if there is a definitive guide to follow with regards to the blend modes, I saw one on vray.info and its pretty much same setup you have but it just doesnt seem to work!

Cheers for any advice you can give

Adam

CGTalk Moderation
03-06-2010, 09:19 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.