PDA

View Full Version : Ambient Occlusion Troubles Mental Ray 2009


mgkaplan
05-05-2009, 09:55 AM
Hello all,

Just upgraded to Maya 2009 and I'm having trouble getting my AO pass to work with the new mental ray render pass system. I created a new render layer, added my desired objects, and set an AO preset for the layer. However, with that render layer selected, when I hit render it treats it as if it were just the master layer... that is, no AO.

When I do a batch render, it renders out the AO layer and the master layer, but the AO layer isn't coming out properly. It's entirely white except for the background, like a white silhouette on black.

I've been trying to figure this out for awhile today and google hasn't been of much help. Any help would be greatly appreciated.

ytse77
05-05-2009, 05:06 PM
I think you might have to turn on "ambient occlusion" in the indirect lighting section of the mental ray render settings.

mgkaplan
05-05-2009, 07:22 PM
Thanks ytse77, but unfortunately I have had that enabled and it still doesn't work. Is there some fundamental difference between 2008 and 2009's pass system aside from the interface? Do the presets not actually set up the pass?

Galakgorr
05-05-2009, 10:16 PM
try setting up an AO layer manually

-override reflections/refractions/max depth to 1/1/2
-override camera bg color to white
-disable final gather
-remove any existing lights
-make sure raytracing is enabled
-create a surface shader, assign texture mib_amb_occlusion
-assign shader to all objects
-make sure you're not tonemapping that layer

mgkaplan
05-06-2009, 01:44 AM
Thanks for the reply. I can definetly set up AO the manual way, but I really want to get the pass system working properly (might as well just go back to 2008 for my purposes). I tried downloading someone else's .mb that has AO set up and that wasn't working so I'm going to try and reinstall.

mgkaplan
05-06-2009, 09:44 AM
I read the documentation a little better and discovered part of my problem. I was trying to load the AO pass without actually rendering it. Evidently... I have to render out the beauty pass always and the AO will render in the background.

Does anyone know how I can just render out an AO pass without the beauty?

Rofideo
05-21-2009, 12:20 AM
to render only the Oclusion just turn off the beauty render in the layers (only unselect the chechbox on left)

Have a nice day

By the way in the render settings chose render in layered PSD (file type)

Galakgorr
05-21-2009, 01:06 AM
if you mean you're trying to get AO out of the passes system based on a mia_material_x_passes, it won't really work. the AO actually comes out as part of your "indirect" buffer.

if you set up custom color buffers in your scene, you could get an AO pass as a render buffer but it wouldn't match your mia_material's built-in AO, obviously. i don't know of a way to get AO from the mia_material separate from the indirect buffer.

francomanko
05-24-2009, 07:34 AM
the last post just sums up maya these days for me.....I'm sure Autodesk are trying to get rid of maya by making previously simple things convoluted...there again, I think my brain might be dying trying to keep up with all these new features :)

CGTalk Moderation
05-24-2009, 07:34 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.