PDA

View Full Version : g-buffer exctract problem in combustion


cmauceri3d
03-22-2009, 10:14 AM
Hi,

I don't know very well combustion, so I'm sure that is an error of mine. I've a character animated in a background, the camera doesn't move so for accelerate rendering times, I've rendered the background in 1 frame, and the character in a sequence of rpf files with the ground, for the final gather coloring the character, and an object wich receive shadows from the character, but this object is rendered with a matte shadow material, in order to keep just the shadows, because it is rendered with the background too. The character rendering sequence is in rpf with an obgect Id for the ground.
My problem is that, when I extract the ground with the gbuffer extract, the matted object turn black.... I don't understand because this object doesn't have any alpha channel, as it's a matte shadows material.

I know that my explanation si a little heavy to understand if it's necessary I will post a picture to illustrate my problem.

Thamkd a lot for your Help.

Chris.

dnashj33
03-22-2009, 10:52 AM
Use the "Show G-Buffer" operator to make sure that the ground has a good Object ID or Material ID to which you can use for the extraction. When you render, make the shadow matte a separate render pass (PNG would be a good format for this) and simply import that into Combustion as a second layer...using the Multiply blending mode. This way it doesn't interfere with any of you G-Buffer elements and you can tweak the shadow's appearance in post (blur, opacity or color correction) separately. Same exact thing goes for your Ambient Occlusion pass.

cmauceri3d
03-22-2009, 11:52 AM
ok Thanks a lot

CGTalk Moderation
03-22-2009, 11:52 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.