PDA

View Full Version : Problem with facing particles in PF


fabriciomicheli
02-26-2009, 07:57 PM
Hi guys!
Im doing some tests and I applied a Shape Facing Operator to a Flow. I create a material with some opacity map, but when I render, the particles cast shadows over other objects. I turn off cast shadows from the particle flow object properties, but it seems that doesnt work at all...
Why do you think is it happening this way?
I append here an image with the flow.

My idea is to integrate seamlessly particles with each other to get a soft look, so I decided to use opacity maps.
Is there another way to create a soft look in particles (i dont want to perceive them as simple dots...)?

Well thanks a lot guys in advance!!!

Piflik
02-26-2009, 09:51 PM
Firstly, having a Spawn Test set to 'by travel distance' without a output event can cause really heavy calculation times and unstable scenes, since every spawned particle spawns a particle itself and so on, causing exponentially increasing particle counts. (very bad...)

Secondly, you can select your lights and exclude the PF-System from shadow casting or disable Cast Shadows and Receive Shadows in the PFlow Event's properties.

Thirdly, you can use Motion Blur to get seamless particles.

fabriciomicheli
02-27-2009, 10:01 AM
Hey man thanks a lot. I see that! youre right... I got confused 'cause I wanted to get a kinda particle trail made with particles spawned from the first particle event... Is there a more simple way to do that? I mean keeping the flow stability as you say.

Piflik
02-27-2009, 11:19 AM
All you have to do is move all the Operators beneath the spawn test to a new event and wire the outpot of the Spawn to this event. The parent particles are invisible, but spawn new particles with the desired look as they travel.

You can of course also instance all the operators instead of moving them, so that the parent particles are visible, too.

In any case you'll end up with three events: One to birth the particles, one for the Trails' Parents and one for the Trails itself.

3DMadness
02-27-2009, 07:10 PM
You have to choose not to cast shadow for each PF event. Right click on the particle view for the event and go to options, there you turn of cast shadow for the event. ;)

CGTalk Moderation
02-27-2009, 07:10 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.