PDA

View Full Version : meshop.attach + retain material IDs?


legie
01-12-2009, 11:39 AM
I am trying to use the meshop.attach function but it is always messing up my material Ids of the source object. I tried all the function's options but not matter what, after I execute meshop.attach the material Ids of the source mesh end up wrong. When I do the same by hitting the buttons in the max interface, it works fine. Furthermore the polyop.attach function works nicely as well. It is only the meshop.attach that is causing problems with the Material IDs. Any ideas?

thanx, Lena

ZeBoxx2
01-12-2009, 12:54 PM
hmm.. the only thing I've noticed is that when the objects don't have a multimaterial assigned that covers the material IDs of the faces, meshop.attach decides those material IDs are pointless and discards them. Might that be what's going on in your case as well? If so, then first assigning a multimaterial with enough submaterials to cover the maximum material ID in the object might 'fix' it. Seems odd, though.

legie
01-12-2009, 02:39 PM
Well, my material (source and target actually have the same material) has enough IDs for all the material IDs in the object. What I did forget to mention though is that after executing the attach command the material itself is condensed as well, even with the option "condenseMat:false" set. I have been testing this for quite a while now with all kinds of setups and I really can't see what might cause the problem and what exactly is going on.

CGTalk Moderation
01-12-2009, 02:39 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.