PDA

View Full Version : Rendering blank space = forever


xsitar
01-10-2009, 05:33 PM
Why does it take forever in XSI to render blank space around my object?

I'm rendering a hi-res single still image with one object in the middle and there's nothing else around it and yet it's taking forever to render because for some reason the blank space is "rendering" too.

Any suggestions?

mattmos
01-10-2009, 05:55 PM
Change the clipping plane of your camera? The far plane should be no further than you need to render the object. Check you don't have more ray bounces than you need (defraction/reflection). Not sure what's causing it to be honest, my blank space usually renders pretty immediately... Are you sure its the blank space that is taking the time?

xsitar
01-12-2009, 10:42 PM
Thanks, i did try many settings and adjustments but it didn't really change much or nothing at all.

Can it be that mental ray is just a slow renderer? Comparing it's scanline speed to the scanline renderer in 3ds max the latter seems like 10x faster or faster.

tc
01-13-2009, 10:58 PM
do you have lots of channels?
If yes, mentalray settings>framebuffer>advancded settings>on-disk framebuffer, uncheck this option.

it doest take forever to render black spaces here, I guess you have some wrong setup on your scene.

EdHarriss
01-14-2009, 07:03 PM
You don't happen to have really high anti-aliasing or very low sampling contrast settings?

Those will make even a blank scene render slowly.

tc
01-14-2009, 07:08 PM
yeah.. min level should be 0 or smaller...
you could set it to 1 if you have issues with AA... if you put min level the same as max level mentalray will throw samples everywhere including the black spaces.

Mic_Ma
01-15-2009, 12:08 AM
do you have photons in your scene?

CGTalk Moderation
01-15-2009, 12:08 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.