PDA

View Full Version : MD nightmare


grafikdon
06-23-2003, 06:40 AM
Hi L'wavers. I have taken a break from modeling the characters for my short and decided to take a shot at cloth simulation since there will be a lot of cloth involved. Here is a sample of what I come up with. The aim was to test the relationship between the legs and the loose cloths around them, as you can see the coilision object cuts through cloth even when I set the skin thickness to 0.09. Everything was fine including the flow of the cloth but I am having a hard time trying to stop the object from cutting through the cloth.
Any suggestions will be highly appreciated cause I have narrowed my hours of sleep to four and three 'cause of this. Yaaawwwwwn. I gotta go work on the storyboard for a few hours before I hit the sack. I will post some models and character designs soon.

G'nite folkz.

SplineGod
06-23-2003, 10:27 AM
You can tweak forever or just make the polys on the leg transparent.

grafikdon
06-23-2003, 12:09 PM
Splendid. That reply has a big flavour of sarcasm. I selected the polygons enclosed by the cloth ,gave them a surface and hid them from the camera. That wasn't bad but is that really an ideal approach? There has to be a way out of this problem order than hiding polygons from the camera.

terryford
06-23-2003, 01:28 PM
I haven't messed with MD for a while but there's a couple of things you could try; increase the Calculation Resolution in MD options (this can increase calculation times drastically), and if your objects are subpatched check that the cage version of the cloth is dense enough so that it can rest on the deforming geometry without polygons cutting through (MD only works on the low-res vertices, not the subpatched ones).


Regards,
Terry

Tudor
06-23-2003, 01:37 PM
You can always increase the density of the deformed mesh.
If I get this right, points on the deformed object collide with the poly on the collision object. This way it is very easy for the collision object to show through the cloth. More density in the cloth = less error. Or just increase the skin thickness even more.

Monty
06-23-2003, 02:53 PM
I would just increase thickness bit by bit

Monty
06-23-2003, 03:11 PM
I know that this has been posted here before, but it so useful here it is again:
http://forums.newtek.com/discus/messages/2/27478.html?

uncommongrafx
06-23-2003, 04:06 PM
Ya know Larry,
I have been dicking with a scene for some time now and have to admit: that's the best/quickest fix for not pulling out more hair!!

And grafikdon, I saw his answer and found it to be 'production' quality advice: get it done now and get paid. ;)
If you've got good motion in the pants, this advice might get you moving on to the next phase of your anim.

Good luck!

HowardM
06-23-2003, 06:20 PM
...like they said, Increase your points, that should help...and play with the skin thickness.

Terry, are you sure SubD meshes arent calculated? My water/taffy scene (http://www.cgtalk.com/showthread.php?s=&threadid=69032) uses a SubD mesh with not too many points in the original cage...and it works pretty well....hmm ill have to do some tests.

terryford
06-23-2003, 07:14 PM
Originally posted by HowardM
Terry, are you sure SubD meshes arent calculated?
I think so but I had to check because it's so long since I've used it (it might have been updated), I just did a quick cloth/ball test with a simple quad as the cloth; if the edges of the (low res) cloth miss the ball it'll pass right through, no matter how fine the subdivision. A subdiv object will work with MD, but it only calculares collision for the low res vertices.


Regards,
Terry

anieves
06-23-2003, 07:20 PM
Originally posted by terryford
I think so but I had to check because it's so long since I've used it (it might have been updated), I just did a quick cloth/ball test with a simple quad as the cloth; if the edges of the (low res) cloth miss the ball it'll pass right through, no matter how fine the subdivision. A subdiv object will work with MD, but it only calculares collision for the low res vertices.


Regards,
Terry

Is this documented in the manual?:argh:
I don't remember reading that.

SplineGod
06-23-2003, 07:46 PM
Originally posted by grafikdon
Splendid. That reply has a big flavour of sarcasm. I selected the polygons enclosed by the cloth ,gave them a surface and hid them from the camera. That wasn't bad but is that really an ideal approach? There has to be a way out of this problem order than hiding polygons from the camera.
There was no sarcasm. What I suggested is a perfectly vailid solution. People seem to be more worried with getting some kind of "accurate" simulation rather then producing a shot. I look at it this way; Is it faster to fix some things by taking a few seconds to hide it or spend another 3 hours tweaking settings to keep the polys from poking thru? Is it faster to fix a few frames in Photoshop or afteraffects?
I use things like MD to get close to the effect I want and then tweak it using easier/faster methods later. Typically to make the simulation more accurate you just need lots and lots polygons and lots and lots of math and math = time.
The ideal solution is one that gets you to a final result in the time frame alotted. I always think of how to cheat these things because it doesnt pay to beat yourself to death for that last 10 - 20%. Nobody will ever see the final result and say, "did you ONLY use motion designer to do this?"

Celshader
06-23-2003, 07:57 PM
Originally posted by grafikdon
...as you can see the coilision object cuts through cloth even when I set the skin thickness to 0.09. Everything was fine including the flow of the cloth but I am having a hard time trying to stop the object from cutting through the cloth.
Any suggestions will be highly appreciated...

Are the arm and cloth both subpatched objects...? If so, be warned that MD looks at the points and point placement of the object before subdivision occurs. Maybe the "arm" object doesn't have enough polys for a smooth collision surface, or maybe the cloth object already intersects the arm in its unsubdivided state.

To see what MD sees, go to the first frame and set both Display Level SubD's to 0. This will keep MD from displaying on a subD'ed object, but you'll see exactly what MD sees.

---

A Skin Thickness of .09 places the collision "force field" 9 centimeters above each collision poly. Is this arm to scale, or is it several meters long? If it is not to scale, you might need to further increase the Skin Thickness on the arm. To see how much distance lies between the arm and the cloth, use the Measure tool in Modeler (CTRL-Q).

---

Another possibility is to start with far more "breathing room" between the cloth and the arm. If this makes the sleeve too big for your comfort, reduce Shrink to 80-90%. This way the sleeve will contract around the collision surface, and it might be happier that way.

---

If the cloth is SubD'ed, make sure it has enough points to curve around the bend "arm." Again, see what it looks like at a SubD level of 0. That's if it's SubD'ed.

$0.02

HowardM
06-23-2003, 08:44 PM
hmm but again Jen and Terry, about lowcage vs. subd...my subdD water object is only a few polys, then subd'ed...so wouldnt the taffy settings not work right, where it conforms around the ball? and wouldnt the water look alot worse?
Maybe its the edge of a subd poly that doesnt work that way, but the middle is fine?

edit: hmmm, you were right, it does only matter how detailed the cage is, not the # of subds! heh, guess my water was just the right amount to get things going....

grafikdon
06-25-2003, 11:28 AM
Splinegod, I do apologize for my misrepresentation of your advise. I fanally got it right this time. Adding more polys to the cloth object got rid of the problem( after I got fed up with increased skin thickness that never worked) though it stressed the crap out of my computer. I will now look for ways to cheat and make this more lenient on my poor pc.:D:D

SplineGod
06-25-2003, 07:19 PM
Cheating is your friend :)

Castius
06-25-2003, 08:31 PM
Celshader pretty much said it all. You still end up hiding the collision mesh most of the time anyway. Who is going to see it? Just wanted to repeat that Md hates hard edges for collisions. bevel any edge that might aproach 45 dagrees.

tests I did today.
cloth (http://www.steelronin.com/temp/cloth05.mpeg)
MD_settings (http://www.steelronin.com/temp/MD_cloth.txt)

I also set fiber to be 25% under object properly
and increased the calc res to higher then 10 i think i did 100 for this test.

PS. anyone else notice that if you change the steps it alwasy goes back to 1?
7.5c win2k

HowardM
06-25-2003, 09:03 PM
ya, the step goes back to one because you must also change the step in the timeline to equal the same #...stooopid bug! 7.5 even....

Did you add pressure effect? I think that or the fiber at 25% is why your cloth buldges where its hitting the hard edge.
try putting them back to 0 and you should have smooth cloth...
:)

Celshader
06-25-2003, 09:24 PM
Originally posted by Castius
I also set fiber to be 25% under object properly

A word of caution about Fiber Structure. What it does is look at the orientation of the object at frame 0. All edges aligned with the Y axis keep their MD settings; all edges aligned with the XZ plane lose their Spring force. Setting Fiber Structure to 100% causes a total loss of Spring force for all edges aligned with the XZ plane.

Fiber Structure is great for creating the movement of a grass skirt or mass of hair, but it might not give you results that you like for cloth.

I used Fiber Structure for my hair tests here:
http://www.celshader.com/gallery/md/

Castius
06-25-2003, 09:32 PM
Thanks thats good to know.

CGTalk Moderation
01-15-2006, 12:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.