PDA

View Full Version : tail rigging with spline ik


MeLtingBrAinZ
12-20-2008, 03:08 PM
hi there! i am rigging a character with a pretty long tail and wanted to have a fluid and smooth motion to it..so i aplied to it spline ik but i noticed that the bones are twisting and when they twist the model just breaks...is there any way i can stop bones twisting on the x axis?

edit: my software is 3ds max 2009....

shinyprem
12-24-2008, 08:55 AM
Hi...
Its due to the ikspline's "Curve" have it into ur motion hierarchy. Try shifting it!

Rgds,

MeLtingBrAinZ
12-24-2008, 09:40 AM
Hi...
Its due to the ikspline's "Curve" have it into ur motion hierarchy. Try shifting it!

Rgds,thnx for your reply! can you please tell me with more details what do i do exactly?

MolemanSD7
12-24-2008, 03:13 PM
My initial take would be to look in the help docs for information on the advanced twist attributes. This will show you how to setup the spline so the joints know which way is "up" and increase the stability of the rig. You can also use it to propagate twisting down the length of the tail.

MeLtingBrAinZ
12-24-2008, 03:18 PM
My initial take would be to look in the help docs for information on the advanced twist attributes. This will show you how to setup the spline so the joints know which way is "up" and increase the stability of the rig. You can also use it to propagate twisting down the length of the tail.thanx moleman for your reply..actually i searched the help files but i could not find anything helpfull...is there something i can do from the motion panel? like canceling the x axis rotation to the bones or to the spline?

c000be
12-25-2008, 02:23 PM
make sure that all of the local rotation axis are pointing the same way, even the very last one. also, never move the root joint, start the spline IK from the 2nd joint up, that may be why your whole rig is deforming. hope this helps, but you haven't provided any pictures of the initial rig and one of the unintended deformation.

MeLtingBrAinZ
12-25-2008, 02:44 PM
make sure that all of the local rotation axis are pointing the same way, even the very last one. also, never move the root joint, start the spline IK from the 2nd joint up, that may be why your whole rig is deforming. hope this helps, but you haven't provided any pictures of the initial rig and one of the unintended deformation.thanks for the reply, sorry i made a mistake on my first post- i said that the model breaks, what i wanted to say is that the tail of my character breaks when i start to move the spline ik controls cause of the rotation on x axis...

so i tested something i went on the hierarchy tab and i deactivated the rotation on x axis on every bone...that thing worked for all the tail bones except the base one...and that made the tail going out of control...

CGTalk Moderation
12-25-2008, 02:44 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.