PDA

View Full Version : 2 questions: copy paste and Crazy F curves?


Mechis
06-18-2003, 02:26 AM
Hi,
I have two questions for y'all.
1) This seems simple. I cannot seem to get copy/paste to work. I would like to be able to copy the movement or rotation of one body part and paste that same movement or rotation onto the body part at a different time. What I have tried: doing copy/paste by right clicking on a control item, doing copy/paste by right clicking on a keyframe, doing copy/paste by right clicking on a keyframe in the dopesheet. None of these seem to work for me.

2) I'm not sure if the following is a bug or what, because it only happens occasionally, sometimes the f-curves window shows the curves fine.

Sometimes I will place keyframes down and on the keyframes the control rig hits the poses I placed, HOWEVER, in between the keyframes, the rig does something ridiculous, like the controls fly off my character and contort the model. I wanted to see the F-curves of the control to see if it was an interpolation problem. However, when I opened the f-curves window for the control, all I saw was a straight line- no keyframes or anything. I just saw horizontal lines.

Any help is appreciated. Thank you!

Mechis
06-18-2003, 05:32 AM
I finally figured out what I was doing wrong with copy/paste. What you need to do, is copy the keyframe, then DESELECT the keyframe, move the time slider to the new frame and then paste the keyframe. I did not realize that I had to deselect the the keyframe I was copying from.
Does anyone have any idea about my problem with the f-curve editor?
Thanks!

Pedrotheartist
06-18-2003, 11:36 PM
Deselecting the keyframe to copy and paste is a right pain, I got caught out on that one.

I haven't had the problem of what you are describing about not seeing your f-curves of your selected effector of your control rig.

Two reasons I can think of top of my head are:

1)Are you viewing the correct layer of your keys i.e. base layer or Layer one?

2)Are you keying in Full Body, Body Parts or selection. If its the last two, then you need to make sure you select the correct effector to see the f-curves.

If you got keys on your Transport Controls and you have selected the rotation and translation attributes of your f-curves, then that does sounds like a bug to me.

Mechis
06-19-2003, 12:15 AM
Hey Pedrotheartist,
Thanks for the comment. I've been messing with MB some more and I think that my problem was that my transport controls were not snapping on frames. As a result, I was making keyframes that were CLOSE to each other (as in sub-frame close), but not exactly on the same frame. For some reason, I think that that caused MB to freak out and that caused the skeleton controls to go crazy and the f-curves window to malfunction.
It seems odd to me that Motionbuilder gives you the option to make sub-frame keyframes, but does not respond well when you place sub-frame keyframes close to each other.
I need to play a little more, but I'm guessing that that is the problem.

Anyone else? Thanks!

CurtisG
06-26-2003, 02:01 AM
Hi Mechis,

It's a question of math. If you have two keyframes close enough together, the system has to find a way to compute a curve, based on the tangent handles, from the first key to the second. If the keys are too close together, the only way to create this curve is by doing these 'crazy' curves, that are way off the charts. It's best just to work with Snap on Frames turned on.

Cheers,

CGTalk Moderation
01-15-2006, 11:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.