PDA

View Full Version : steampunk darth vader - with a big of problem - please help


southparx
10-15-2008, 09:50 AM
Hello folks i have a major problem and i really hope the folks here who has many exp in low poly/normal map can help me overcome this;

anyways right now im in the middle of transferring high res details in zbrush to my low poly mesh -

http://i207.photobucket.com/albums/bb131/south_parx/steampunk/projecting.jpg

but im facing polygon 'spikes' everywhere..

http://i207.photobucket.com/albums/bb131/south_parx/steampunk/projectAll.jpg

as you can see in the image, the spikes are really bad when i try to projectAll: multiple subtools in one shot..

then i had the idea to separate each 'parts' of the low poly into different polygroup with the multiple UV space method.. worked pretty well in case of the helmet..

http://i207.photobucket.com/albums/bb131/south_parx/steampunk/Helmetl.jpg

but not without problem, as you can see i have spikes especially in the 'open edges' area ...

i'm guessing the explanation for this is because i have multiple subtools and ONE single 'low poly' mesh to transfer the details to, some polygon that are facing outward catch the detail from one subtool and the polygons facing inward catch detail from the other subtool... hence the projection result are 'mixed up' pretty bad

Also another huge problem is the polygons surrounding the open edges is VERY very hard to smooth! i use smooth intensity 100 and still it wont budge, for example this one zoomed in (not just this one - they're practically everywhere the spikes are)

http://i207.photobucket.com/albums/bb131/south_parx/steampunk/openEdge.jpg

btw please dont mind the 'faceted' polygons - i didnt put all the subtools in highest level when i screenshot this

Anyways i saw Paraglis low poly workflow, and had the idea of generating the normal map in max instead, but my max freeze when the 8 million low poly mesh is successfully imported.. so i guess im stuck to generating the normal map in zbrush.

Also one of my biggest mistake is probably from the beginning i put all the parts in their own subtool ... i didn't know until now that this create such a big problem because this is my first time trying to create 'high rez' low polygon character

Okay sorry for the length explanation but if anyone has any trick to remedy the spikes or another workaround, without me having to redo all the details by hand on the low poly mesh - i will be really really grateful

i look forward to your help.. thank you

Clanker
10-20-2008, 12:15 PM
zbrush 3.1 supports now normal map generation between 2 differents meshes via zmapper tool. You don't have to transfer your high poly on the low. This is more the workflow for retopologisation.

southparx
10-20-2008, 06:02 PM
hi Clanker..

ohhh reallyy i didnt know that - thanks for the info..

i have 3 gnomonology videos about the normal map by Scott Spencer but as far as i remember none of them show anything about it..

can i ask you really quick how you go about doing this - generating NM from 2 different meshes i mean

thanks in advance and have a nice day,
andrew.

Clanker
10-20-2008, 07:46 PM
Hey
Yeah, this was impossible before zbrush 3 and the zmapper plug-in.
Here's a quick workflow

1 : Draw your high poly model then go down to its lowest level.
2 : Press zmapper in top left of the screen.
3: Under "Projection" at the bottom of zmapper menu, press "capture current mesh".
4 : Click again on zmapper to get out, then load your low poly tool and draw it.
5: Define a new texture with the final normal map resolution
6 : Press again zmapper. Under display, choose "2.tangent space nm"
7 : Click on "create projected normal map", then you'll have a preview.
8 : Finally, click on zmapper again and there you are, your texture is the new normal map.

For more informations about zmapper :
http://www.pixologic.com/docs/index.php/ZMapper_Reference
http://www.zbrush.info/docs/index.php/ZMapper_Projection#Aligning_the_Initial_and_New_Base_Meshes

Have a nice day too :)

southparx
10-29-2008, 12:55 PM
Hello Clanker,

sorry ive been busy catching up with stuffs i didnt have time to reply

but thanks for the steps, it's very useful - ive finally able to do the projection within zmapper

again thanks and have a nice day

~cheers,
andrew

CGTalk Moderation
10-29-2008, 12:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.