PDA

View Full Version : no sun and sky in occlusion


=LuxX=
09-16-2008, 08:50 AM
fellow maya users,

I got a question about rendering with render layers.
It is possible to turn things of and ont for every pass.
BUt how can i eliminate the physical sun and sky in the occlusion render? ( preset) because when you have the sun and sky on there will be no good occlusion.
But i dont want to delete it all the times when i make a test render.

THe think is i want to let that layer know that sun and sky arent there when he need to render.

Thnx

Helgi
09-16-2008, 10:10 AM
Hi there =LuxX=,

First off, yes it is possible to turn things on and off for every pass, it's called Layer Override. So when you select the layer and change any settings in it, it automatically turns on Layer Override.

So if you want to turn off the Physical Sun and Sky in your AO pass, you should select the AO layer and turn the Multiplier to 0 (inside the mia_physicalsky node) and
right-click and click Create Layer Override.

Cheers :)

=LuxX=
09-16-2008, 10:53 AM
Thnx for you help but still its not correct.

I can overide i can als switch the sky off. and over ride that.. ( but that doesnt the trick also)
i dont get a wite/black image but an grey.
If i put the light down ( of the sun) it also dont help

any other suggestions?
atleast i learned something new.. :D

Helgi
09-16-2008, 11:46 AM
If you only get a grey image which is not affected by the Physical Sun & Sky then it's just a matter of tweaking the shader (inside the hypershade you should have a surface shader and inside the color attr. is the AO shader). Because Ambient Occlusion is not affected by lights it's calculated from normal direction.

Could you post an image of the AO render you get?

romeu
09-16-2008, 12:04 PM
you also have to break the conections of the tonemaper in the camera, because oclusion don't have to be tonemaped.

naik
09-16-2008, 12:36 PM
you also have to break the conections of the tonemaper in the camera, because oclusion don't have to be tonemaped.

Exactly - that will do the trick.

=LuxX=
09-16-2008, 01:11 PM
well ill look to this in a sec.. first i make a poly ship in a nurb one... damn this is tricky but i think its actualy going to work :D

=LuxX=
09-16-2008, 02:30 PM
Oki the nurb thingy was a hell .. ( dint actualy work :P )


BUT... i went to the camera options and at the mentalray tab i broke the conections with the envoirenment shader and the lens shader ( with override) and thadaa.. it worked . ow also i turned off the miaphysicalsky ( with override) in the camera.

Thnx allot mate's

=LuxX=
09-16-2008, 03:42 PM
OK again i did a test..

the only thing i needed to do was:
- select the Oclussion render layer
- Go to the camera atribute aditor and then go to the mental ray tab
- there right klick on envoirenmental and klick overide
- then break the connection
- then right klick the Lensshader and turnon override
- then break the connection of the lens shader and tadaa ready.

CGTalk Moderation
09-16-2008, 03:42 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.