PDA

View Full Version : Particles just won't listen


TiMrozek
08-14-2008, 11:13 PM
I have a scene that involves multiple emitters filling an object but not leaving the object.

I have done this a few times with no problems but now it's giving me problems.

I have the emitters within the geometry and have them set to collide with my mesh. It almost works but I keep getting stray particles that are somehow making there way out of the geometry. I know the mesh has no holes in it.

Anyone have any ideas?

KamiNoNamida
08-14-2008, 11:45 PM
I haven't used particles for some time now, but I'm guessing this could be some substepping issue. I don't remember if it's called like this with particles (as it is with nCloth) but there has to be some kind of iteration/step setting.
Or, you can speed your particles down until they're slow enough for maya to detect all collisions.

Hope that helps somehow :)

TiMrozek
08-14-2008, 11:54 PM
Slowing is working a bit. Guessing I'll just have to keep playing with a few attributes until I get them to stay contained. Thanks :)

gmask
08-15-2008, 12:22 AM
Slowing is working a bit. Guessing I'll just have to keep playing with a few attributes until I get them to stay contained. Thanks :)

You can also try increasing the Tessellation Factor in the geoConnector that is create for the collision object.

KamiNoNamida
08-15-2008, 12:31 AM
Slowing is working a bit. Guessing I'll just have to keep playing with a few attributes until I get them to stay contained. Thanks :)
Ok, it kinda tickled me so I went and checked out the particles attributes, but couldn't be sure that the trace depth attribute was what I thought it was. Well, it is :D

So, you can, aside from slowing particles down, push the trace depth up so that maya splits the frames into more iterrations for collisions detection.
The doc also confirmed the doubty idea I had that increasing the tessellation (in the geoConnector node) will help having more precise results.

So you now have 3 options to solve the problem, and you should probably try the 3 to see which one (or which combinasion) will be the fatest for the best result.

Voila ;)

Aikiman
08-15-2008, 12:47 AM
Increase collision tesselations to a high value like 1000-2000.

CGTalk Moderation
08-15-2008, 12:47 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.