PDA

View Full Version : Python not recognized with Xsi 7


svero
08-14-2008, 05:36 AM
I've installed Python, and PyWin32. I've run the suggested com extention script mentioned in the xsi guides docs. But despite all that xsi doesn't seem to want to list Python as a scripting language under preferences, and when I try to load python based plugins it gives me an error saying that they are invalid. Anyone have any ideas why python is not showing up?

ThE_JacO
08-14-2008, 11:26 AM
Only thing I can think of is that you might have got the wrong pywin32. You need to get one that ties to your python version for it to work correctly.
Normally installing python first then pywin is all you need to do.

Uninstall/reinstall is also an option, python is fairly thorough in cleaning after itself when you uninstall, so it's viable without ending up with a ton of registry and configuration garbage.

revert
08-14-2008, 03:39 PM
Are you running x32 or x64?

svero
08-14-2008, 07:12 PM
I checked the pywin32 version and it seems to match the version of python I installed (2.5) -- I uninstalled and reinstalled and still nothing shows up.

I'm running x32

- S

ThE_JacO
08-15-2008, 02:42 AM
Check softimage's wiki, there's an article on it on how to get python running.
I never had those problems so I'm not sure I can really help.

svero
08-15-2008, 03:12 AM
Yes I read the wiki docs and the xsi guides etc.. Maybe I'm missing something crucial but so far I haven't a clue. It seems like I've done everything that I'm supposed to do or that they suggest trying. Python itself runs ok from explorer. Maybe if I had a better idea of how the two apps interfaced. I think it must be looking for some kind of registered COM object. If you're running python is it also version 2.5? And this is working with xsi 7?

ThE_JacO
08-15-2008, 04:24 AM
2.5 with pywin32 for 2.5 working fine here with v7, on xp32 and vista32.
The way they interface is through pywin32, which is a wrapper for the activestuff(tm)/COM architecture for XSI to interface with python.
First time I see somebody going through all the steps in the wiki and not getting it running, I'm just as stumped as you are sorry.

CGTalk Moderation
08-15-2008, 04:24 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.