PDA

View Full Version : Blend shape oddity


Serashi
08-14-2008, 03:33 AM
Hi Everyone

Quick question. i have my model smooth bound to a skeleton, weighted it and added influence objects. next step is to add blendshape for some corrective deformation. the shoulder as usual is the trickiest.

all vaules are zeroes out on the model, the controls.
i dulicate the model, make the blend shape change, move the blendshape node under the skin node. and test it out. the shoulder reactes as it should....but. for some reason the geomtry of the hands and lower arms move slightly also on both sides. and i never touched them. tried several times, same result. Is there anything obvious i missed or you smart riggers out there know of?


Thank You
Serashi

isoparmB
08-14-2008, 05:54 AM
To be safe when you duplicate your geometry to create blend targets, set all deformers' envelope attributes to zero. This ensures that you duplicate your object prior to any deformation that your model might have undergone (make sure to set them to 1 again after duplication).

Also, make sure the deformation order of your model is as follows : blednshape first, then skin. If not, this can be reversed easily in the inputs section of your maya window (next to the make live magnet).

Buexe
08-14-2008, 06:54 AM
amen to isoparmB, he knows this stuff, make sure you understand his words and you undertood most there is to know about MAYA rigging, seriously. Blendshape and skinning are the usual suspects of character animation, get them right(especially the deformation order).

Serashi
08-14-2008, 10:46 PM
Thanks for your help. managed to get the tiny movement away from the arms. hope the rest goes smooth without any problems. eager to animate:)

Cheers
Serashi

CGTalk Moderation
08-14-2008, 10:46 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.