PDA

View Full Version : Smooth Binding breaks Component Editor??


Jon Jones
05-29-2003, 12:46 AM
Okay I'm having a bit of a problem with the Component Editor that I've been testing and trying to get to manifest itself again. Been wrestling with it since yesterday and I've got the information I need on it now, I think.

I'm using Maya 4.0.2 on Windows XP.

My problem is that whenever I Smooth Bind my character to his skeleton, the SkinClusters tab in the Component Editor breaks. By 'breaks' I mean the first tab that has 'hold', the object name and the vertex number is scaled out infinitely far to the right. Everything looks and works beautifully right up until I click 'smooth bind'. There is no scalable edge on that first tab so I can't simply grab it and scroll it back to how it should be. This is a picture of what it looks like before and after:

http://www.planetquake.com/shattered/shine/images03/ihatemaya-beforeafter.jpg

What baffles me is that other models display perfectly and the component editor looks just fine. I don't know what's wrong with my model. It's split up into a few separate objects but I'm only binding one at a time, which shouldn't be a problem. All the history is deleted on all of them. When I smooth bind, the model reacts exactly as it should... it's just that damned Component Editor.

I've tried this in Windows 2000, in XP, in XP with the Windows Classic theme enabled, with dual monitors enabled and disabled, and even in Maya 4.5 and it's all still the same.

What could possibly be happening here? This model is already overdue and these delays are killing me... any help is appreciated.

dmcgrath
05-29-2003, 02:29 AM
Okay the one thing that confuses me is the fact I only see ONE vertex in that list. vtx(156)
Can you give us more information on how you are skinning?
Are you selecting a vertex at a time or skin?

Jon Jones
05-29-2003, 07:04 AM
I was just selecting the one vertex as an example. There are plenty of them to work with, I assure you. heh :)

What I'm doing is just tweaking the locational skinning that Smooth Bind does so the model deforms properly. I was instructed specifically to do them in the Component Editor, individually if necessary.

dmcgrath
05-30-2003, 04:47 AM
I still can't figure out how the mesh ends up like the way you have mentioned it. If I think of something I'll let you know.
(Or hopefully my bump will get someone else to read and reply to this thread that has had this problem.

Matt Leishman
06-03-2003, 07:55 AM
I just barely had the same problem on Saturday in Mid rig on a character. I smooth bound my poly mesh, and now my component editor looks exactly like that, with no fields with values in them when I select ANY of the verts on my mesh. Very vexing indeed, oh well, the paint smooth weights tools still works, but I sure would like to figure out what the deal is too.

beer56
11-16-2004, 02:14 PM
Try to turn off List>Show Path Name in Component Editor. The joint fields will never be far away.

CGTalk Moderation
01-15-2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.