PDA

View Full Version : swapping references killing my ik arm setup?


anthonymcgrath
07-08-2008, 08:47 AM
hi all
I have a character on a bike. Both the bike and the character are referenced into the scene. The plan is to be able to animate with one character then swap out the character and make tweaks on the 2nd character.

His arms are using ik to pin his hands to the bike and then another ik handle to from wrist to fingertips to pin his hand on the handlebars - so in all I have 4 ik handles.

However when I swap out the character it seems to lose the ik handle connections.

Has anyone had this problem before? The arm joints in both characters are all named the same and everything so I'm completely lost with it all :(

When I check the hypergraph upstream connections on the ik handle its replaced an Iksystem node that controlled global ik controls with a "sharedReferenceNode". I checked the help files but I cant find any more info on why its doing that but if I bring back character1 that "sharedReferenceNode" switches back to a IkSystem node.

please please any info or thoughts you may have would be greatly appreciated - I've lost sleep on this one now :(

anthonymcgrath
07-08-2008, 10:33 AM
ok seem to have it sorted. Turns out there was a node called the ikRPsolver - when I swapped out for another character it killed this node replacing it with a "sharedReferenceNode". This would result in the ik handles not working whatsoever :(

so using the following:

createNode ikRPsolver;

and then using the connection editor I connected the .nodestate of the ikRPsolver to the ikSolver attribute of each of the 4 broken ik handles.

seems to have fixed the issue - whenever I swap a character out now it just works.

thank heavens.

CGTalk Moderation
07-08-2008, 10:33 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.