PDA

View Full Version : Weighting Problem with Meta Effectors


Pixelclown
07-04-2008, 01:25 PM
Maybe I just can't find the right trigger, but I think I ran into a little problem here.

I've an eyeball and want to rotate it with a single bone. I added a Meta Effector to the Mesh and positioned a new Effector at the eyeball and used the 'All connected' option. Everything works fine. The Bone just rotates the eyeball.

Now I want to place a bone for deformation at the eyelid. I placed the bone, it's pretty near the eyeball of course, added another Meta Effector to the Mesh and added a Effector as well. I placed this one at the eyelid and switched it to 'constant' as well. The eyeball is not in its range, just some vertices of the eyelid.

The bone of the eyelid works fine, it just moves the eyelid. But the bone of the eye now doesn't move the whole eyeball but just a part. It seams to me that the default influence of the eyelid bone has influence on the eyeball bone. How that?

I tried it with different Meta Effectors, Bones and Positions. When I switch the Mesh to weighted shading I see the weighting of the bones and the eyebone has less weighting as it should have.

Anyone an idea?

thanks for reading
Jonas

edit: I attached some files which show the right weighting for the eyelid bone and the wrong for the eye bone.

Tama
07-04-2008, 03:54 PM
I've found that loading in the eyeballs as seperate objects from the body mesh makes rigging
them a lot less complex. No weighting required for the eyes.

CGTalk Moderation
07-04-2008, 03:54 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.