PDA

View Full Version : Particle Draw in Direct3D


Mike Truly
06-11-2008, 04:20 AM
I use MAX2008_32, dual QuadroFX 3450s, and Direct3D. I have noticed recently that my PFlow particles display strangely in the viewport under certain situations. (I can't remember if they always have done this with this config but it's just recently started to bother me).

If I have a situation where there are only particles on the screen displayed as ticks for example, they display as you would expect. But if I am using PFlow to create those particles on the surface of another object (such as a sphere) and the viewport is in shaded mode... the ticks are not displayed over the sphere surface that is facing me, they are only displayed at the edges of the sphere where the ticks hang over the object. So it's like the drawing order is wacked. The sphere is drawn in front even though the ticks should be in front.

Is this just the way Direct3D always does this and if I was using SZB all would be fine? (I should note that my display cards are functioning great in all other respects and I'm not eager to update drivers, etc. unless this is a specific known bug that's been fixed or something). Is there a setting that will make the particles drawn in the right order?

Thanks!

charleyc
06-11-2008, 08:07 AM
It has not always been this way, but it has always done it in 2008. I can't remeber off hand if R9 did it, but I think did. Anwy, SZB probably will not do this, but I haven't checked.

Glacierise
06-11-2008, 09:34 AM
I have the same problem with 2008, but with a GF 7600. Only the lines display mode works correctly.

Mike Truly
06-11-2008, 01:33 PM
Thanks for verifying guys! No big deal but definitely annoying. I can always shift to SZB if necessary.

Thanks again.

Glacierise
06-11-2008, 01:57 PM
I think the software mode should be better with particles anyway - D3D is not so good with displaying lots and lots of individual objects.

holycause
06-11-2008, 02:14 PM
I wish i could use the software mode in 64bit :P

makes me crazy the dots size in D3D :S

hvanzon
06-21-2008, 01:38 PM
I still think it's strange that autodesk chooses directx in stead of the opengl. OpenGL is probably faster en more stable. But I'm not a software developer so I guess it has a good reason.

CGTalk Moderation
06-21-2008, 01:38 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.