PDA

View Full Version : rigging gurus please come in


MrWyatt
05-15-2003, 12:41 PM
Hi,
need help for animating a spiraled cable ( is it called that way). I put an IK chain in the middle to let it dangle between two moving parts, and I am quite happy with the motion so far , but I also want the cable to stretch and compress like a cable like that would in reality, but I donīt know how to automate a stretching of the IK chain to achieve that effect, I also would need something like a middle controll handle to be able to dangle also to the sides. can anybody tell me how to set that up.

Thanx
:shrug:

Soeren Nielsen
05-15-2003, 01:11 PM
Im just in the middle of some stuff myself, so I wont have a chance to take a crack at it right now.. .. but you could make a chain of bones that follow the wire (do a curve all the way, convert to polys, and "make skelegons")
Now in layout comes the boring part.. set up a limit for every bone there is, and enable IK.. do a script for it, should be straightforward with lscommander. put in a couple of nulls to control it... if you want to be able to control it even better make a bigger control rig to control the smaller one..
Ill do a quick scene later if I get the time and put it for download.

MrWyatt
05-15-2003, 02:03 PM
donīt know if thatīll work I try to get away with as few bones as possible. there has to be a way of having a straight bone chain that stretches maybe even procedurally like inerita on bones. something like a delay on the motion.

Soeren Nielsen
05-15-2003, 02:15 PM
ít could be done without a big amount of bones, but then you wont be able to get that compress/stretch of the wire without distorting the mesh.. if you do it with alot of bones, it will look alot better, and not distort the mesh.. just hide the bones, and use another smaller rig to control the other bones :)

Castius
05-15-2003, 02:26 PM
http://www.worley.com/polk/polk_dangle.html
or fi bezier bend
http://www.infoseek.livedoor.com/~f_ichikawa/plugin-page.html
or try to apply md after you bones deformation

MrWyatt
05-15-2003, 02:34 PM
as i said, the dangling is not the problem. that works allready but the cable, as you see should also bounce up and down in the middle, getting longer.

policarpo
05-15-2003, 03:56 PM
have you seen this?

http://www.digitalproducer.com/2003/05_may/tutorials/05_12/charac_anim3.htm

MrWyatt
05-15-2003, 04:20 PM
tried that, but it doesnt work.
1. it needs to dangle between two points
2. it has to stretch and compress while doing that.

till now all solutions only cover the dangle part which i have solved throu IK chain between two nulls. none of the above tips works for the stretch and compress part. any idea on that would be very helpfull.

by the way thanks for the help anyway, even when i had the same thoughts pretty much at the same time.

Mike RB
05-15-2003, 04:28 PM
Do a search for chainmail in this forum. Thats the method I would use. I'd model your cable in a neutral pose, then model a segmented box that sits in the same sapce, id use MD on that box to do everything, from the bouncing motion to the streching.

Mike

SplineGod
05-15-2003, 08:03 PM
Originally posted by MrWyatt
Hi,
need help for animating a spiraled cable ( is it called that way). I put an IK chain in the middle to let it dangle between two moving parts, and I am quite happy with the motion so far , but I also want the cable to stretch and compress like a cable like that would in reality, but I donīt know how to automate a stretching of the IK chain to achieve that effect, I also would need something like a middle controll handle to be able to dangle also to the sides. can anybody tell me how to set that up.

Thanx
:shrug:
HEREs (http://www.3dtrainingonline.com/examples/phonecord.zip) something that might do the trick. Right now each null is not parented to anything but you can parent them to each other and setup Ik on them if you wish. You can probably get away with less bones too.

scotttygett
05-16-2003, 07:11 AM
On a whim, I visited an old MD experiment file, where the chains looked like jello, and I'm inclined to think MikeRB's way will work for you, as long as it's within MD's range.

When I dashed off another spring for MD, I used array, so I guess a morph target arrayed stretched doesn't work, even with the maps and all??

gr4g
05-16-2003, 09:32 AM
hey,

you should try out the new spline deform plugin (splinamate.p) in lightwave 7.5b
i made a quick example.

download scene (http://gr4g.100megsfree5.com/spirale.zip)

if you use messiah you could also use the expression called IKTel which allows the bones to stretch when you move the ik goal outside the reach of the ik chain

greets,

gregor

Joviex
05-16-2003, 10:04 AM
Originally posted by gr4g
hey,

download scene (http://gr4g.100megsfree5.com/spirale.zip)




NO REALLY!!! Thanks for the spam.

gr4g
05-16-2003, 11:29 AM
Originally posted by amorano
NO REALLY!!! Thanks for the spam.


???

MrWyatt
05-16-2003, 12:56 PM
Originally posted by SplineGod
HEREs (http://www.3dtrainingonline.com/examples/phonecord.zip) something that might do the trick. Right now each null is not parented to anything but you can parent them to each other and setup Ik on them if you wish. You can probably get away with less bones too.

sorry but something in your scene crashes my system completely. it loads the object and freezes the screen. I had twice to pull the plug literally to be able to reboot. does anybody else has this problem?
Iīm still on LW 7.5 could that be the reason?

gr4g
05-16-2003, 02:22 PM
i am also on 7.5 and lightwave crashes when i load the scene

MrWyatt
05-16-2003, 03:49 PM
iīm sure the scene was corrupted during compression.
can you zip it again Larry? please

SplineGod
05-16-2003, 04:54 PM
Try it again. This was done in 7.5c which may be the problem.

MrWyatt
05-16-2003, 05:13 PM
Originally posted by SplineGod
Try it again. This was done in 7.5c which may be the problem.

yeah, seems to be exactly that, just crashed again. did you use any plugs that donīt work in 7.5 ? one reason more not to update. if ever I was forced to go back to 7.5 because of some lscript misteriously not working in 7.5c, i would be really screwed if the objects made in 7.5c crashed my system

SplineGod
05-16-2003, 10:51 PM
Originally posted by MrWyatt
yeah, seems to be exactly that, just crashed again. did you use any plugs that donīt work in 7.5 ? one reason more not to update. if ever I was forced to go back to 7.5 because of some lscript misteriously not working in 7.5c, i would be really screwed if the objects made in 7.5c crashed my system
I didnt use anything speical, jsut the built in stuff.
Why dontyou create a 7.5 folder and a 7.5c folder.....thats what I did. :)

MrWyatt
05-17-2003, 11:56 AM
will do that

MrWyatt
05-17-2003, 12:20 PM
just updated to 7.5c and your scene still crashes my system. Installed LW on a completly new rocking computer and it still crashes. Larry, could you post some screenshots on how to set it up because the scene dont want to work

SplineGod
05-17-2003, 09:32 PM
I emailed the .lwo and .lws directly to you this time... :)

CGTalk Moderation
01-15-2006, 03:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.