PDA

View Full Version : Baking w/ MR + farm = major artifacts, farm idling


JustinD
04-18-2008, 03:36 PM
Hello everyone,

We're running into some problems with our cobbled-together render farm, when trying to use MR to bake texture maps. Our assistant producer and artist have put together the information below. Hopefully someone here can lend us a hand with getting these issues squashed! It's not much, but I'll be happy to hand out copies of our software and some t-shirts as thanks! (http://www.freeverse.com)

Here goes!

--------------------

So first the basics:

We're using Maya 2008 Extension 2 along with Mental Ray Satellite version 3.6.51. (That is, mental ray for Maya.)

Hardware-wise, our artist has an Alienware Desktop PC connected via Gigabit Ethernet to our newly-assembled render farm: a PowerMac G5, 2 Dell desktops and an HP desktop machine.

We are attempting to use our render farm to bake 12 texture maps.

We've started by selecting the items we want to bake, and creating 2 bake sets with ~10 pieces each.

Use Bake Set Override is turned OFF so that mental ray will use each bake set's settings.

Both bake sets share the same settings with the exception of size: one is 2048 x 2048 while the other is 1024 x 1024.

There are 11 area lights, 4 point lights and 1 ambient light being used.

Orthogonal Reflection is OFF
Bake Alpha is ON
Bake Shadows is ON
Color Mode is set to LIGHT & COLOR
Normal Direction is set to SURFACE FRONT
# of Samples is 4

The problems we're having are twofold:

---

1. When trying to bake previously without the use of bake sets, the render farm was never used. Mental Ray seemed to only take advantage of the main machine Maya was installed on (our artist's Alienware machine).

Now that we're using bake sets, the render farm is occasionally being used by mental ray...

When leaving the office at 6pm all 4 machines were being used; upon returning the following morning, only the PowerMac G5 remained working, and at 100% CPU (normally it's pegged at 200% - both processors being used.) The 3 PCs had stopped working on the baking. We're not sure exactly why this happened.

Upon further investigation, it looks like the render farm is only used occasionally when we try to do this. For instance, some of the 3D environments we're created can be baked over the farm, but others, the render farm gets a quick shot of data over the network but then just idles. FWIW, all single scene renders that we do through a perspective camera do make use of the farm from start to finish, so it looks like everything it set up okay. Perhaps it's something we're doing in the 3D environments themselves? I've read a few threads on lighting when baking with MR, but none seem to really address the render farm issue...

---

2. 5 out of 12 maps were complete, but 4 of them had severe artifacting (screenshot @ http://dev.freeverse.com/baking-woes-and-tribulations.jpg), and the fifth baked out quite a bit darker than we had desired (although baking even on our single machine seems to produce maps slightly darker than we planned, so the darkness may be expected). The real problem is the artifacting/corruption.

Additionally, none of the alpha channels were baked despite that option being turned on.

---

Our primary concern is with the artifacting/corrupting of the completed maps. Any ideas why it is occurring?

(For what its worth... when rendering a single scene through a perspective camera (no bake sets or anything), via mental ray and the render farm, using the Final Gathering option, we do see similar corruption.)

We also need to figure out why the alpha channels are not being baked. The option was turned ON, so is there something that we missed, or perhaps a light source type that Mental Ray Satellite doesn't like?

Lastly, why the render farm stopped working (or stopped being fed data?) at some point that night. Based on single scene renders through a perspective camera, the render farm indeed works for big jobs, so we're pretty sure that's setup properly. Any reasons why the farm would stop work on the baking?

Thanks for all your help!

~ Kevin O., Lucas G. & Justin D.

foggyball
04-18-2008, 08:51 PM
Try taking the Mac out of your farm. Renderfarms don't like mixed systems. We have found that even PPC and Intel Macs don't play nicely together in the farm.
I can't really answer your baking questions as it's not a work flow I use.

igi
04-18-2008, 09:46 PM
I never managed to bake over the network, so I just bake few lightmaps on each workstation separately. I know, with renderfarm thats a little bit harder.
Maybe this (http://forums.cgsociety.org/showthread.php?f=87&t=621867) recent post from max will help you

CGTalk Moderation
04-18-2008, 09:46 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.