PDA

View Full Version : Blendshape deforms after changing Deformation order


Tiberius07
04-09-2008, 07:47 PM
Hi!
I got a little problem with my blendshapes.
When I add a blendshape deformer to my model everything is alright, and the blenshape blends perferctly.
BUT because i want to move the face I have to put the blendNode in the deformation order before the skincluster. After that change, when I try to blend the blendshape, it's deforming a little bit. I looks like that the face geometry gets smooved out and the edges of the model shrink.

Hope you know a solution. The deformation is minimal but the model is a face and everytime i do a blink the face changes a little bit and that looks strange.

Thx for every answer

meljunky
04-30-2008, 11:08 PM
You may have the problem solved already....

Sounds like the head was duplicated while the skinCluster has changed the position of the verts in the head. In other words, some joint(s) were moved. That why the blendShapes work while the order of deformation was in the wrong order. Once you fix the order, the blend shapes are evaluating based off head orginal position. Which causes verts to shift when you activate the blendshapes.

If you turn off any skinClusters and deformers you have before you duplicate the head will prevent any problems with the character not being in its bind pose.

-brian
www.meljunky.com (http://www.meljunky.com)

CGTalk Moderation
04-30-2008, 11:08 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.