PDA

View Full Version : Blocky Shadows


byranx
04-08-2008, 12:19 AM
Hey everyone

I got a problem that might require a simple solution but unfortunately I haven't found it yet. I got blocky shadows (as if I was using depth map with really low settings). Except the settings I'm using seem to be fairly high. I'm attaching an image but I can describe what settings I have. This test has only one directional light at 0.8 intensity with depth map shadows (detailed) at 1024 resolution with a filter size of 6 and 21 samples. I'm rendering in Mental Ray, segment shadows, (detailed shadows selected), production quality with adaptive anti-aliasing at 4 samples max. Default lighting is disabled and resolution of the image is 640 x 480. There is a skydome but I made sure it can't cast/receive shadows. The set is fairly large (the ground for this shot is about 5000 across). From what I can also see is that the shadows looked detached too and not even appearing on some objects (bias for depth map shadow is at 0). I do have "auto focus" turned on as well as "use mid dist", i'm not sure if that would be a problem or not.

I'd really appreciate it if anyone could help me out. Thanks

-Brian

YourDaftPunk
04-08-2008, 05:50 AM
Make sure you are using a spotlight and not a directional light. Make sure the cone of the spotlight is as small an angle as it can be while still covering the part of your scene that the camera scenes.

That being said, next go to the Spotlight Attributes > Mental Ray > Shadows section and tick the box that says "Use mental ray shadow map overrides."

Input these settings:
Resolution: 1048
Samples: 48
Softness: 0.005
Bias: 0.0

Feel free to bump up the settings to 2048 / 64. Should render smooth and fast. If you are not raytracing anything, in your render globals, switch to the Rasterizer instead of Scanline or Raytracer for rendering and control the quality through Visibility Samples and Shading Quality. Should be lightning fast, even with larger dmap shadow resolutions.

Also, you might want to check the documents on Detail Shadow maps. You turn them on in the light attributes and *lower* accuracy values are better. It's superb for hair, grass, etc.

-shawn

Sharky0815
04-09-2008, 02:38 PM
You can also turn off "cast shadows" for the groundplane so it doesn´t get included in the shadowmap.

CGTalk Moderation
04-09-2008, 02:38 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.