PDA

View Full Version : Ocean wake clipping problem


quajibo
03-28-2008, 06:39 PM
Hi all,

I'm having issues with an ocean wake. The wake waves all get clipped at about 1 unit of height, creating what looks like a plateau. The wake fluid's height is far above where it gets clipped. Any ideas?

Also I'm having trouble rendering the wake. The resolution of the wake is very high and the preview plane makes it look like it has plenty of res, but when I render the ocean the wake waves are super low rez, with weird angles instead of curves.

Thanks for the help,

Matt

Duncan
03-28-2008, 07:12 PM
It sounds like the bounding box scale on your shape is not large enough (in the attribute editor under displacement map options on the shape node). Clicking on "calculate bounding box scale" (in that same block) should help. The shape's tranform scale should also be proportional (scaleX=Y=Z), otherwise the displacement may not match the preview plane. Also your displacement tessellation is likely too low for your view (tessellation attributes on the shape node). Note that with the default ocean nurbs plane created for the ocean feature it has triangles concentrated in the center of the circle, so that there are fewer triangles towards the horizon. It is good to position this such that the center of the circle is relatively close to the center of your view. Also make sure that featureDisplacement is OFF on your shape.

Duncan

CGTalk Moderation
03-28-2008, 07:12 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.