PDA

View Full Version : 8.5 sp1 fluid cache name bug ?


oglop
03-23-2008, 06:58 AM
i found that if my scene name contains ď_Ē, and if i disable Copy Cache File Locally after i created fluid cache. when i hit save file , the Cache File name attr of the fluid cache node will be in correct

How to reproduce this bug:

1. setup a new project, open a new scene, drop in a fluid container with emitter

2. create cache

3.save scene as fluid_bug.mb , now everything works correctly, my cache file name will be fluid_bug.mb_fluidShape1.mcfp

4. but if i uncheck Copy Cache File Locally attr on fluid cache node. hit the browse cache button on the fluid cache node, select the cache, now cache name atter is data\ fluid_bug.mb_fluidShape1.mcfp and save my scene . my cache name instantly changes into
data\fluid_bug.mb_bug\data\fluid_bug.mb_fluidShape1.mcfp

and next time i open maya, of course maya complains it canít find the cache file, and this scene contains a uncached fluid. blahblah

if ur cache name doesn't mess up , save ur scene and reopen it , sometimes it doesn't.

Is there a fix for this? i think this can be fixed by modifying some mel scripts.

maya 8.5 sp1 22705272232-700503 on winxp eng


edit:
i found that i should never use the browse fluid cache button to select a cache if copy locally is off.because when u browse a cache file. the cache name will became data\xxxx.mcfp and then when u save ur scene, the cache name will be incorrect


How do reproduce :

still iíve not found a workaround.

what is the recommended way of network rendering scene that contain fluids?

1. i set up my fluid containers and tweak after i got satisfied results

2. i disable evaluation of the container, ( but i found that this is not enough, the copyLocally attr still do what it should do , and scene loading and saving is very slow if u have a big cache ), so i disable the copyLocally attr too, setup another container , and tweak ( i may have multiple containers in my scene.)

3. because iím constantly tweaking , inevitably i have to save multiple versions of my scene, say my scene name was fluid.mb, maybe the next version is fluid_001.mb, but the problem is when copyLocally attr is off, maya will not make a new copy of the existing fluid cache.So i have to manually browse the cache on the cache node tab. and if u browse, the cache name will change from say fluid.mb_fluidShape1.mcfp to something like data\fluid.mb_fluidShape1.mcfp, and when u save your scene as fluid_001.mb, the cache name will change into a weird string. not the supposed fluid_001.mb_fluidShape1.mcfp

4. after u save as ur scene multiple times, the cache name will become longer and longer .... it seems when u r saving, maya takes the first _ occurance in the cache name as the divider between scene name and fluid name, fluid_001.mb_fluidShape1.mcfp will become
fluid_001.mb_001.mb_fluidShape1.mcfp after saving, ( maya thinks _001.mb_fluidShape1.mcfp is the fluid container name ), if your scene name doesnít contain any _ and ur fluid container name doesnít contain any _, of course there will be no problem

ahh....

edit: i gave up, i ended up using OpOf cache, and scene loading speed was back to normal, but the tradeoff is u canít append or truncate ur cache according to the doc.

CGTalk Moderation
03-23-2008, 06:58 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.