PDA

View Full Version : snapping graphic issue


Bucket
03-20-2008, 07:40 AM
I've been experimenting with snapping some.. and I think I might've messed up the settings in xsi.. I'm not sure. For instance. When I look at two cubes. Take the two cubes. And select one of the vertices and point snap it to a point on the opposing cube. and then another point.. So that I would have two edges perfectly aligned. I zoom waay waaay waaay in... And as I continue to zoom in.. on the two so called perectlly aligned edges. The edges begin to shake and show that they are not perfectly aligned. I went to preferences and restored the defaults.. out of fear I messed something up. I still have the problem though.

Is this just a graphical glitch from zooming too far in?

tarkovsky
03-20-2008, 11:44 AM
Same issue here, and bit suprised by this. Never been an issue though. The only similar problem I've encountered, is when importing IGES curves/nurbs. If they are too far away from the center of scene, they will draw with jaggies and have inaccurate snapping. Move Center to Bounding Box fixes it.

tark

bmcpherson
03-20-2008, 12:53 PM
I am pretty sure the problem is not snapping but in the OpenGL display.

OpenGL is using single-precision floating point and small differences in the two object's global transforms are being magnified when zooming in too far. (similar to how setting the near clipping plane in OpenGL to a really small value will cause clipping artifacts in the 3D view)

Cheers!
--
Brent

ThE_JacO
03-20-2008, 12:55 PM
renamed the title for you.
"oh man stupid question" is NOT how you title a thread. Please in the future title them so that the subject is obvious without having to read several lines into the post.

CGTalk Moderation
03-20-2008, 12:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.