PDA

View Full Version : MetaEffectors ineffective?


NikkiC2
03-19-2008, 01:32 AM
I had serious problems getting MetaEffectors to work in the versions previous to 3, and I seem to have similar ones with the current. I have a single ME attached to a cat, but any values I change appear to be completely ineffective. No change is made to the weighting or size. It appears completely impenetrable. The cat shows completely white, but there's no sign of any influence. I'd expect a black sphere showing where the ME is positioned. I'm wondering whether I've missed something crucial? I keep flipping back to the CatFur demo and can't find any difference between the settings for ME and my scene.

It seems to be really fussy which objects MEs will work with. I just created a scene with a ball and applied a ME. Works. But not within my cat scene.

Nikki

peksi
03-19-2008, 09:15 AM
Remember that order of effectors is important. If negative effector is before positive, it's first taking off from zero and then adding the positive. If I remember correctly the order of effectors is defined in setup->tools tab in tool list.

NikkiC2
03-19-2008, 02:33 PM
There's only one ME in my test scene. I've clicked every button, changed all values between -1,000,000 to +1,000,000. Nada. I'll resort to UV weight maps. This has to be a bug. I did open up the CatFur example scene with its MEs all over the place. I closed down MS and reopened the scene and all appeared OK. Something's not quite right.

Nikki

peksi
03-19-2008, 03:14 PM
Ok, just in case: did you remember to "Add Items to Weight Drawing List"? Select your MetaEffector tool (not the effector sub-tool that is child of that tool). Go to "Weight List" tab of this tool, while holding ctrl select your mesh and click "Add Items to Weight Drawing List"

NikkiC2
03-19-2008, 03:58 PM
peksi,

Yes, I've done that. I have two test scenes. One with a sphere with MEs actually doing what they're supposed to, another with a cat model where MEs quite stubburnly refuse to play.

Nikki

Tama
03-19-2008, 04:18 PM
I'd suggest providing the scene so others can pick it apart and investigate more directly.

NikkiC2
03-19-2008, 06:58 PM
Tama,

That's a good idea. I have a number of issues. I loaded my cat model straight into a blank scene and got a ME to show up its influence as a darkened or lightened patch. Problem now is that although the ME shows its restricted influence through the Weight view, the influence it's having is completely even across the WHOLE model when influencing hair length when Min and Max are set to 2.0 and 0.2 respectively in the MetaEffector panel. This is how CatFur.fxs is configured. Strangely, the CatFur demo does not appear to render out the influence of the MEs on the hair, unless it's incredibly subtle. It again appears a constant value, although in the DirectX view the hair is shorter on the nose, legs and feet. This could be an issue related to trying to reverse the effects of MEs. But what do I know!

Nikki

CGTalk Moderation
03-19-2008, 06:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.