PDA

View Full Version : Flicker Issues with Messiah


StOuen
03-16-2008, 08:54 PM
Hi. Got really bad UI flickering and overlap (occurs when running the cursor over the main tabs at top and expands and contracts lower graph editor and other context menus). This has started since I installed MA 2.5c on a machine with 2x Nvidia Quadro FX / Xeon Quad Core. Have updated drivers.

Anyone else got this going on?

Much obliged.

Parsec3d
03-16-2008, 10:40 PM
go to the advanced tab on the windows display options find Troubleshoot and step down one level on hardware acceleration.. if that works ,, u might also want to tweak more specific settings , but don't worry if that worked messiah won't be slow..

StOuen
03-17-2008, 08:10 PM
Just the ticket. Thanks for your help - much appreciated.

lostpencil
03-25-2008, 03:07 PM
I'm having the same problem: Vista 64bit, Quad 3Ghz, GeForce 8800GTX running ForceWare version 169.25. No such option in Vista. I played with some of the 3d settings but nothing seems to work. Suggestions?

Lex1342
03-25-2008, 06:49 PM
Hi,

someone in the community gave me the hint to use the predefined settings for Maya and it worked flawlessly. Does the Forceware options include presets for 3D progs?
Hope it helps.

LX

lostpencil
03-25-2008, 07:13 PM
Hi LX, thanks for the reply. Unfortunately it has no predefined settings for Maya (just most Games), but Maya, Max, and Soft run fine using the defaults. I tried different settings, but nothing seemed to make a difference for messiah. Anyone have messiah running under Vista 64 bit using the 8800? If so, what version of the drivers and what settings are you using?

lanosrep1
03-25-2008, 11:52 PM
First of all.. Welcome back Paul.. Haven't seen you in these parts for quite some time:)

don't have Vista yet.. so.. maybe shooting in the dark, but I have had the most success by changing the bit depth in the 3d settings on an assortment of cards, ATI , Intel, NVidia..by changing the settings for Depth buffer to 16bit as well as Texture buffer. If your drivers have settings for those.. give it a shot..
G.

I'm having the same problem: Vista 64bit, Quad 3Ghz, GeForce 8800GTX running ForceWare version 169.25. No such option in Vista. I played with some of the 3d settings but nothing seems to work. Suggestions?

lostpencil
03-26-2008, 12:08 PM
Hey Gary, thanks for the welcome back! It has been awhile, been real busy! I checked to see if there were settings in the nvidia control panel and I don't have any for changing bit settings on depth or texture buffer. Any further directions?

StOuen
03-26-2008, 12:28 PM
<Off topic>

Hi Paul, just want to say got a selection of your training materials from my LightWave CA days and I still refer to them - quality stuff. Hope you find a solution to your display problem.

Cheers!

(Holty)

lostpencil
03-26-2008, 03:47 PM
Hey Chris! Thanks for the kind words, I'm glad they were useful!

So I also figured out the flickering problem. Here is the trick. Download (http://http://downloads.guru3d.com/downloadget.php?id=163&file=7&evp=2d213e528fb556c354432a3976bff55a), install and run Rivatuner 2.08 (runs on 64 bit Vista no problem). Then under Driver Settings, click on 'customize'. Then select the OpenGL icon to open up OpenGL Tweaks. Under the Back/Depth Buffering tab there is a list box next to 'Back Buffer Flipping Mode' - that should be set to 'Block Transfer' (not Auto Select). I suspect that Maya/Max/Soft either turn this mode on automatically (or they do things differently in OpenGL than messiah). Anyway, now to relearn messiah and learn whats new in 3.0!

lanosrep1
03-26-2008, 05:57 PM
Glad you found a fix Paul.. Good info for those of us that will eventually have to go to Vista.. ahhh yuck :) Sorry.. hate bloatware..

So glad you have made it back! You were one of the inpiring ones back in the early days of Messiah!!

Hey Chris! Thanks for the kind words, I'm glad they were useful!

So I also figured out the flickering problem. Here is the trick. Download (http://http://downloads.guru3d.com/downloadget.php?id=163&file=7&evp=2d213e528fb556c354432a3976bff55a), install and run Rivatuner 2.08 (runs on 64 bit Vista no problem). Then under Driver Settings, click on 'customize'. Then select the OpenGL icon to open up OpenGL Tweaks. Under the Back/Depth Buffering tab there is a list box next to 'Back Buffer Flipping Mode' - that should be set to 'Block Transfer' (not Auto Select). I suspect that Maya/Max/Soft either turn this mode on automatically (or they do things differently in OpenGL than messiah). Anyway, now to relearn messiah and learn whats new in 3.0!

Julez4001
10-22-2008, 03:18 PM
Bump cuz its always needed.

palpal
11-29-2008, 06:59 PM
I run a ati card with catalyst and has the same error now!

Your PAL :bounce:

jgj
02-06-2009, 07:31 PM
Just wanted to add my own experience getting rid of the flicker on my GeForce 8800 and Vista 64:

Rivatuner is the ticket, however, it can't install in Vista 64 SP1 because the command-line 'turn off driver signature checking' command is no longer supported. The work around is to turn it off during boot up by hitting F8 (exactly when is hard to judge -- I just kept tapping it during the boot sequence) to get the advanced boot up options, where you can turn off Driver Signature Checking. Then install Rivatuner, and follow lostpencil's instructions, which work like a charm.

-Jim

Womball
02-19-2009, 04:19 AM
This worked great for me! Does Rivaturner have to be on all the time though?

jgj
02-21-2009, 05:19 PM
Rivatuner seems to just change obscure registry settings for video cards, so it defintely doesn't have to be kept running. Could even be uninstalled when done, ...I think.

-Jim

Wegg
04-18-2009, 06:53 PM
Correct. It just dials in the features to support a more "pure" OpenGL environment that messiah needs.

lostpencil
04-18-2009, 07:11 PM
Update: another way to get it to work without Rivatuner is to just turn on antialiasing using your display settings (for a Nvidia card: Nvidia Control Panel->Global Settings->Antialiasing Mode, set it to 'Override any appliaction setting', then under the Antialising Setting, set it to 2x or higher).

Wegg
04-18-2009, 08:00 PM
Thats the only way I can get it to work with my ATI card in Vista. Thanks lostpencil.

rcallicotte
04-18-2009, 11:20 PM
Using RivaTuner's D3D override by adding pMG's executable to the Overrider did it.

Julez4001
04-22-2009, 07:07 PM
Update: another way to get it to work without Rivatuner is to just turn on antialiasing using your display settings (for a Nvidia card: Nvidia Control Panel->Global Settings->Antialiasing Mode, set it to 'Override any appliaction setting', then under the Antialising Setting, set it to 2x or higher).

Hey Lost..what kind of videocard do you have now.
My 7600 broke, so I have a 9600 and did as you suggested however I get minor flicker inthe item list (instead of opengl window)..anything else to fine tune it.

lostpencil
04-22-2009, 07:44 PM
Mine is an 8800 GTX... I don't know of any other settings that may help, but it could be a driver version issue as well. So basically what I did to figure out the problem was try different versions and in each version I tried turning on/off things until I exhausted the possibilities. Then I picked the best combo. I'm currently running ForceWare version 175.16 as drivers for the card. Hope that helps!

kursad_pileksuz
04-08-2010, 04:45 PM
Hmm

Never had this issue until I have started using Windows7. I tried all the fixes but none seem to help me with my Nvidia card

Tama
04-08-2010, 08:40 PM
Hmm

Never had this issue until I have started using Windows7. I tried all the fixes but none seem to help me with my Nvidia card

Did you view this forum thread?

http://setuptab.com/index.php/topic,347.0.html

Dogzer
07-23-2010, 06:24 PM
go to the advanced tab on the windows display options find Troubleshoot and step down one level on hardware acceleration.. if that works ,, u might also want to tweak more specific settings , but don't worry if that worked messiah won't be slow..

Now where's that advanced tab? Is it inside messiah? I just can't find it, especially with everything flickering, it drives me f*cking insane.

geothefaust
07-25-2010, 06:16 PM
Now where's that advanced tab? Is it inside messiah? I just can't find it, especially with everything flickering, it drives me f*cking insane.


No, it is related to your video card settings, those cannot be changed inside of Messiah.


Why not use the Messiah forums at setuptab.com? There is a thread there on this very topic which actually helps and has specific information which will get you back on track. The thread can be found here:

http://setuptab.com/index.php/topic,347.0.html

CGTalk Moderation
07-25-2010, 06:16 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.