PDA

View Full Version : Turn off AA in mental ray?


TwinsenDude
03-12-2008, 07:54 PM
Hi. I'm currently working on a project for a game company, and we need to output a render that has no antialiasing for one of the render layers.

Does anyone know how to turn off antialiasing in mental ray? It would be especially helpful if it is in a way in which it can be done as a layer override.

I tried lowering the radius of the filter to the minimum of 0.01, and strangely there was no difference in the render :\

danylyon
03-12-2008, 08:12 PM
Set your Sampling Mode to "Fixed Sampling" and max/min to 0/0.
The your multi Pixel filtering to "Box" and filter size to 1.00 1.00.
That should do it.

TwinsenDude
03-13-2008, 02:47 PM
Hmm, this just made the anti-aliasing worse quality, it didn't remove it.

See, I'm rendering out objects as solid colors. I created a shader, set the color to black, the diffuse to 0, and then put the incandescence at the color I wanted. I did this for a number of objects, and the problem is that the anti-aliasing is creating in-between colors, and for the game engine we can't have any in-between colors, it has to be just the pure solid colors.

So I need anti aliasing completely off, which I can't figure out how to do.

Bitter
03-13-2008, 08:01 PM
Do you mean a constant color instead of gradients? Use a surface shader or something like Puppets constant shader. That will produce a flat color for everything without "in-between" colors.

asche
03-14-2008, 08:40 AM
aliasing is the effect that causes this steps on edges and textures

antialiasing is the method to remove it

so you want to turn off antialiasing ?! dont think so
try high sample values, such as 1 and 3, combined with a filter like mitchell at value 5 and contrast settings at 0.02

drmz
03-14-2008, 12:26 PM
No, he WILL disable Antialiasing. In GameEngines for some Plattforms like Nintendo DS you have to work with indexed colors. 256 colors for example. So you need exact colors for shading and no interpolated edges.
Set antialiasing to 0/0 Box and under Framebuffer disable "Interpolate Samples".
This is Maya 7 - Mental Ray Renderer.


DrmZ.

TwinsenDude
04-11-2008, 04:49 PM
Drmz, that gets me really close.

However, when I zoom very close in on the image, I see slight color differences.

I'm rendering out objects for a game iwth solid colors. So I've set the color of the object to complete black, and I set the incandescence to the color I want it to be.

However when I render it using the settings you provided, the color is slightly different around the edges from it is in the middle... :\

kjaft
04-14-2008, 09:17 AM
You probably didn't turn diffuse to 0, still getting real shading not 100% overlayed by the incandescence color. Btw, why are u using incandescence? If you really want solid colors use a surface shader
.

ovendelon
04-14-2008, 09:51 AM
I think what you are looking for is

1. Leave the AA at normal sampling levels
2. turn off PREMULTIPLY in your primary frame buffer

this will not antialias against the background, if this is for prerendered games where you can't use alpha channel, and have to 'key' the object from a color

Omnis
08-18-2008, 12:51 PM
I was looking for the same answers...than I found a solution and decided to post it here...a bit late though, hope you found a way out in these months anyway :D

set the sampling mode to "fixed sampling" and than the max sampling to 0 (so u get 1 sample per pixel).
if you chose a box filter you can use any value between 0.501 and 0.999 for the Filter size.
Don't ask me to explain this XD

ciao !

CGTalk Moderation
08-18-2008, 12:51 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.