PDA

View Full Version : sprite rendering problem in mental ray


rperez333
03-05-2008, 12:35 PM
I created a particle animation with sprites and tried to add an image sequence to the sprites. The idea here is to replace each sprite with a warrior running cycle, recorded from a green screen, and using goals, create a army from them.

I had to use Mental Ray as the renderer because maya hardware doesn't cast shadows neither calculate occlusion, to help me compose this on the background.

I was able to get the animation working the way I wanted inside Maya as shown in the first image below. However, when I render with Mental Ray, the warriors all render the first image from the loop sequence, like in the second image below. Inside Maya or hardware render, all is correct, the loop is cycled at random start for every particle. I used Sprite Wizard to setup this particles.

I already cached the particles, and tried the export full dag path, in render globals - translation, all without success...

Do I need to set expressions elsewhere to get Mental Ray to render out the correctly?
Thanks,

bruce

http://i257.photobucket.com/albums/hh233/rperez3333/mentalrayproblem.jpg

hkspowers
03-13-2008, 10:29 PM
As far as I know Mental ray does not support custom per particle attributes. Or many pp attributes at all. I would just render out the sprite pass and then comp everything afterwards and fake the shadows etc.

CGTalk Moderation
03-13-2008, 10:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.