PDA

View Full Version : 3.0 MorphBlender & LW = Broken


dustin1138
02-25-2008, 03:21 AM
I cannot get Messiah v3 MorphBlender to work with Lightwave.

Currently, the only way to load up endoMorphs with MorphBlender is using Messiah as a stand-alone. Just like in the posted demo video.

If you use Lightwave it breaks with any approach you take. Examples:

1) Start LW. Start Messiah as a plugin. Load the object (with endoMorphs) in LW. In Messiah select MorphBlender. Under Cluster select New Slider. Select Cluster_ClusterSlider_1 (all of this is the same as the tutorial video). But here's the problem: when you go to select your object under the EndoMorph Obj tab you'll find that it's empty.

2) Start LW. Start Messiah as a plugin. Load the object (with endoMorphs) in Messiah (hit F11 to send to LW). In Messiah select MorphBlender. Under Cluster select New Slider. Select Cluster_ClusterSlider_1 and under EndoMorph Obj select the object. Switch to Animate and add some keyframes to the morph sliders (Also add some motion to the object to prove some info is getting to LW). Swith back to LW. You'll see the object moving around like you keyframed but you'll see that the morphs DID NOT come across.

3) Start Messiah. Load the object (with endoMorphs). Select MorphBlender. Under Cluster select New Slider. Select Cluster_ClusterSlider_1 and under EndoMorph Obj select the object. Switch to Animate and add some keyframes to the morph sliders (Also add some motion to the object). Save the scene in Messiah and exit. Start LW. Start Messiah as a plugin, toggle to it and load the messiah scene (.fxs). Toggle back to LW and scrub. We have motion and we have morphs!!! Yeah! Save the LW scene (since this is the proper saving method - saving with the host app) and exit. Restart LW, start Messiah as a plugin and load the scene. The motion is still there but the morphs are NOW GONE. Toggle over to Messiah and switch to Setup and select the Cluster_ClusterSlider_1. When you now look at the EndoMorph Obj tab you'll find that the object is now missing.

Either this MorphBlender plugin is very broken when used with LW or it was never intended to be used with a host app and only intended for use with Messiah as a stand-alone.
Help?

Wegg
02-25-2008, 04:06 PM
.mdd support has kind of super-seeded the need for Messiah to be used as a plugin. While that SHOULD work as you described, it is probably something none of the testers tried. Your short term solution would be to export out an .mdd of your motion and apply it in Layout. All free with Lightwave and Messiah's native .mdd support.

dustin1138
02-26-2008, 05:35 AM
That's what I was afraid of. I guess the pmG crew is trying to position Messiah as a full stand alone product at the cost of its integrated Lightwave roots.

kursad_pileksuz
02-26-2008, 06:47 AM
Dustin I doubt that is the case. One problem is that lightwave has alot of fixes in recent years and they change their scene and object format all the time. At some point Modo had .lws support in the past but they do not do it anymore because they are tired of constanly reverse engineering it.

I think that at this point the best you can do is write to Pmg and explain the issue with clear steps and example scenes. If it is something on Messiah side Fori would take care of it at some point.

CGTalk Moderation
02-26-2008, 06:47 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.